asterisk-1.8.x: add mysql module
authorJiri Slachta <slachta@cesnet.cz>
Tue, 12 Aug 2014 09:37:46 +0000 (11:37 +0200)
committerJiri Slachta <slachta@cesnet.cz>
Tue, 12 Aug 2014 09:37:46 +0000 (11:37 +0200)
Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
net/asterisk-1.8.x/Makefile

index fe7071b..a9c6891 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=asterisk18
 PKG_VERSION:=1.8.29.0
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE:=asterisk-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.asterisk.org/pub/telephony/asterisk/releases/
@@ -187,6 +187,14 @@ else
        --without-libcurl
 endif
 
+ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk18-mysql),)
+  CONFIGURE_ARGS+= \
+       --with-mysqlclient
+else
+  CONFIGURE_ARGS+= \
+       --without-mysqlclient
+endif
+
 ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk18-pbx-lua),)
   CONFIGURE_ARGS+= \
        --with-lua="$(STAGING_DIR)/usr"
@@ -231,7 +239,6 @@ CONFIGURE_ARGS+= \
        --without-gtk2 \
        --without-isdnnet \
        --without-misdn \
-       --without-mysqlclient \
        --without-nbs \
        --with-ncurses="$(STAGING_DIR)/usr" \
        --without-netsnmp \
@@ -360,6 +367,7 @@ $(eval $(call BuildAsterisk18Module,chan-local,Local proxy channel,An implementa
 $(eval $(call BuildAsterisk18Module,chan-mgcp,MGCP channel,the channel chan_mgcp,,/etc/asterisk/mgcp.conf,mgcp.conf,chan_mgcp,))
 $(eval $(call BuildAsterisk18Module,chan-ooh323,ooH323 channel,the channel chan_ooh323,,/etc/asterisk/ooh323.conf,ooh323.conf,chan_ooh323,))
 $(eval $(call BuildAsterisk18Module,chan-skinny,Skinny channel,the channel chan_skinny,,/etc/asterisk/skinny.conf,skinny.conf,chan_skinny,))
+$(eval $(call BuildAsterisk18Module,mysql,MySQL,MySQL support,+libmysqlclient,/etc/asterisk/res_config_mysql.conf,res_config_mysql.conf,res_config_mysql,))
 $(eval $(call BuildAsterisk18Module,odbc,ODBC,ODBC support,+libpthread +libc +unixodbc,/etc/asterisk/cdr_adaptive_odbc.conf /etc/asterisk/cdr_odbc.conf /etc/asterisk/cel_odbc.conf /etc/asterisk/func_odbc.conf /etc/asterisk/res_odbc.conf,cdr_adaptive_odbc cdr_odbc cel_odbc func_odbc res_odbc,cdr_adaptive_odbc cdr_odbc cel_odbc func_odbc res_config_odbc res_odbc,))
 $(eval $(call BuildAsterisk18Module,pgsql,PostgreSQL,PostgreSQL support,+libpq,/etc/asterisk/cel_pgsql.conf /etc/asterisk/cdr_pgsql.conf /etc/asterisk/res_pgsql.conf,cel_pgsql.conf cdr_pgsql.conf res_pgsql.conf,cel_pgsql cdr_pgsql res_config_pgsql,))
 $(eval $(call BuildAsterisk18Module,pbx-ael,Asterisk Extension Logic,support for symbolic Asterisk Extension Logic,,,extensions.ael,pbx_ael,))