avoid installing internal header files
authorFelix Fietkau <nbd@openwrt.org>
Wed, 25 Sep 2013 07:06:36 +0000 (09:06 +0200)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 25 Sep 2013 07:06:36 +0000 (09:06 +0200)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
CMakeLists.txt

index 1178c62..f6009e7 100644 (file)
@@ -28,8 +28,7 @@ TARGET_LINK_LIBRARIES(ustream-ssl ubox ${SSL_LIB})
 ADD_EXECUTABLE(ustream-example ustream-example.c)
 TARGET_LINK_LIBRARIES(ustream-example ustream-ssl)
 
-FILE(GLOB headers *.h)
-INSTALL(FILES ${headers}
+INSTALL(FILES ustream-ssl.h
        DESTINATION include/libubox
 )
 INSTALL(TARGETS ustream-ssl