avoid installing internal header files
[project/ustream-ssl.git] / CMakeLists.txt
index 6af1750..f6009e7 100644 (file)
@@ -10,7 +10,11 @@ IF(APPLE)
   LINK_DIRECTORIES(/opt/local/lib)
 ENDIF()
 
-IF(CYASSL)
+IF(POLARSSL)
+  ADD_DEFINITIONS(-DHAVE_POLARSSL)
+  SET(SSL_SRC ustream-polarssl.c)
+  SET(SSL_LIB polarssl m)
+ELSEIF(CYASSL)
   SET(SSL_SRC ustream-io-cyassl.c ustream-openssl.c)
   SET(SSL_LIB cyassl m)
 ELSE()
@@ -24,8 +28,7 @@ TARGET_LINK_LIBRARIES(ustream-ssl ubox ${SSL_LIB})
 ADD_EXECUTABLE(ustream-example ustream-example.c)
 TARGET_LINK_LIBRARIES(ustream-example ustream-ssl)
 
-FILE(GLOB headers *.h)
-INSTALL(FILES ${headers}
+INSTALL(FILES ustream-ssl.h
        DESTINATION include/libubox
 )
 INSTALL(TARGETS ustream-ssl