make uqmi_add_error return QMI_CMD_EXIT
[project/uqmi.git] / CMakeLists.txt
index 4db9185..a09865f 100644 (file)
@@ -7,8 +7,8 @@ SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
 
 SET(SOURCES main.c dev.c commands.c qmi-message.c)
 
-find_library(json NAMES json-c json)
-SET(LIBS ubox ubus ${json} blobmsg_json)
+FIND_LIBRARY(json json-c json)
+SET(LIBS ubox blobmsg_json ${json})
 
 IF(DEBUG_PACKET)
   ADD_DEFINITIONS(-DDEBUG_PACKET)