detect the right library name for json-c
authorFelix Fietkau <nbd@openwrt.org>
Tue, 12 Mar 2013 13:37:35 +0000 (14:37 +0100)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 12 Mar 2013 13:37:40 +0000 (14:37 +0100)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
CMakeLists.txt

index cd22fc7..ec45c52 100644 (file)
@@ -69,7 +69,8 @@ IF(UBUS_SUPPORT)
        SET(PLUGINS ${PLUGINS} uhttpd_ubus)
        ADD_DEFINITIONS(-DHAVE_UBUS)
        ADD_LIBRARY(uhttpd_ubus MODULE ubus.c)
-       TARGET_LINK_LIBRARIES(uhttpd_ubus ubus ubox blobmsg_json json)
+       FIND_LIBRARY(libjson NAMES json-c json)
+       TARGET_LINK_LIBRARIES(uhttpd_ubus ubus ubox blobmsg_json ${libjson})
 ENDIF()
 
 IF(PLUGINS)