add -Wmissing-declarations
authorFelix Fietkau <nbd@openwrt.org>
Mon, 31 Dec 2012 17:49:15 +0000 (18:49 +0100)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 31 Dec 2012 17:49:15 +0000 (18:49 +0100)
CMakeLists.txt

index 8e3af4d..c542df6 100644 (file)
@@ -1,7 +1,7 @@
 cmake_minimum_required(VERSION 2.6)
 
 PROJECT(uhttpd C)
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3)
+ADD_DEFINITIONS(-Os -Wall -Werror -Wmissing-declarations --std=gnu99 -g3)
 
 IF(APPLE)
   INCLUDE_DIRECTORIES(/opt/local/include)