http: make ustream_ssl optional, only use provided ssl context
[project/uclient.git] / CMakeLists.txt
index 0d48175..f7fd051 100644 (file)
@@ -13,10 +13,10 @@ IF(APPLE)
 ENDIF()
 
 ADD_LIBRARY(uclient SHARED uclient.c uclient-http.c uclient-utils.c)
-TARGET_LINK_LIBRARIES(uclient ubox ustream-ssl)
+TARGET_LINK_LIBRARIES(uclient ubox dl)
 
 ADD_EXECUTABLE(uclient-example uclient-example.c)
-TARGET_LINK_LIBRARIES(uclient-example uclient)
+TARGET_LINK_LIBRARIES(uclient-example uclient ustream-ssl)
 
 INSTALL(FILES uclient.h uclient-utils.h
        DESTINATION include/libubox