set -O0 for debug builds
authorFelix Fietkau <nbd@openwrt.org>
Tue, 29 Jan 2008 18:20:10 +0000 (19:20 +0100)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 29 Jan 2008 18:20:10 +0000 (19:20 +0100)
Makefile

index ecfa8bc..c136915 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,7 @@
 COPTS=-O2
 CFLAGS=$(COPTS) -fPIC -Wall -pedantic -std=gnu99 -Wno-unused -Werror
 ifneq ($(DEBUG),)
 COPTS=-O2
 CFLAGS=$(COPTS) -fPIC -Wall -pedantic -std=gnu99 -Wno-unused -Werror
 ifneq ($(DEBUG),)
+  COPTS = -O0
   CFLAGS += -g3 -DDEBUG_ALL
 endif
 
   CFLAGS += -g3 -DDEBUG_ALL
 endif