add main directory to include path
authorThomas Gstädtner <thomas@gstaedtner.net>
Sun, 3 Mar 2013 15:20:13 +0000 (16:20 +0100)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 4 Mar 2013 18:17:19 +0000 (19:17 +0100)
CMakeLists.txt

index e3968c8..2a72012 100644 (file)
@@ -11,6 +11,8 @@ OPTION(BUILD_LUA "build Lua binding" ON)
 
 CONFIGURE_FILE( ${CMAKE_SOURCE_DIR}/uci_config.h.in ${CMAKE_SOURCE_DIR}/uci_config.h )
 
 
 CONFIGURE_FILE( ${CMAKE_SOURCE_DIR}/uci_config.h.in ${CMAKE_SOURCE_DIR}/uci_config.h )
 
+INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
+
 SET(LIB_SOURCES libuci.c file.c util.c delta.c parse.c)
 
 ADD_LIBRARY(uci SHARED ${LIB_SOURCES})
 SET(LIB_SOURCES libuci.c file.c util.c delta.c parse.c)
 
 ADD_LIBRARY(uci SHARED ${LIB_SOURCES})