cmake: Fix cli shared linking against ubox
authorAndre Castro <andre.castro.sw@gmail.com>
Fri, 2 Feb 2018 12:04:44 +0000 (12:04 +0000)
committerJohn Crispin <john@phrozen.org>
Mon, 12 Feb 2018 14:29:46 +0000 (15:29 +0100)
The 'ubox' library used in 'cli' target is not using the output of the
'find_library' command. This is a problem when the 'ubox' library is not
located on the standard system library locations.

Use the CMake variable 'ubox', output of 'find_library' call that points
to the library found on the system, instead of hardcoding the library's
name to 'ubox'.

Signed-off-by: Andre Castro <andre.castro.sw@gmail.com>
CMakeLists.txt

index 2df6fa7..170eb0b 100644 (file)
@@ -36,7 +36,7 @@ SET_TARGET_PROPERTIES(cli PROPERTIES OUTPUT_NAME uci)
 IF(BUILD_STATIC)
   TARGET_LINK_LIBRARIES(cli uci-static ${ubox-static})
 ELSE(BUILD_STATIC)
 IF(BUILD_STATIC)
   TARGET_LINK_LIBRARIES(cli uci-static ${ubox-static})
 ELSE(BUILD_STATIC)
-  TARGET_LINK_LIBRARIES(cli uci ubox)
+  TARGET_LINK_LIBRARIES(cli uci ${ubox})
 ENDIF(BUILD_STATIC)
 
 ADD_LIBRARY(ucimap STATIC ucimap.c)
 ENDIF(BUILD_STATIC)
 
 ADD_LIBRARY(ucimap STATIC ucimap.c)