add initial work for option datatype abstraction
[project/uci.git] / Makefile
index 766fccb..ea7d5c7 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,34 +1,35 @@
-VERSION=0.1
+VERSION=0.5
 
-COPTS=-O2
-WOPTS=-pedantic -Wno-unused -Werror
-FPIC=-fPIC
-CFLAGS=$(COPTS) $(WOPTS) -Wall -std=gnu99
+# optional features
+PLUGIN_SUPPORT=1
+DEBUG=0
+DEBUG_TYPECAST=0
+
+include Makefile.inc
 
-AR=ar
-LD=ld
-CC=gcc
 LIBS=-lc
-RANLIB=ranlib
-
-ifneq ($(DEBUG),)
-  COPTS = -O0
-  CFLAGS += -g3 -DDEBUG_ALL
-endif
-OS=$(shell uname)
-ifeq ($(OS),Darwin)
-  SHLIB_EXT=dylib
-  SHLIB_FLAGS=-dylib
-else
-  LD=gcc
-  SHLIB_EXT=so
-  SHLIB_FLAGS=-shared -Wl,-soname,$(SHLIB_FILE)
-endif
 SHLIB_FILE=libuci.$(SHLIB_EXT).$(VERSION)
 
+define add_feature
+       @echo "$(if $(findstring 1,$($(1))),#define UCI_$(1) 1,#undef UCI_$(1))" >> $@.tmp
+endef
+
+LIBUCI_DEPS=file.c history.c list.c util.c uci.h uci_config.h uci_internal.h
+
 all: uci-static uci libuci.$(SHLIB_EXT)
 
-cli.o: cli.c uci.h
+cli.o: cli.c uci.h uci_config.h
+
+uci_config.h: FORCE
+       @rm -f "$@.tmp"
+       $(call add_feature,PLUGIN_SUPPORT)
+       $(call add_feature,DEBUG)
+       $(call add_feature,DEBUG_TYPECAST)
+       @if [ \! -f "$@" ] || ! cmp "$@.tmp" "$@" >/dev/null; then \
+               mv "$@.tmp" "$@"; \
+       else \
+               rm -f "$@.tmp"; \
+       fi
 
 uci: cli.o libuci.$(SHLIB_EXT)
        $(CC) -o $@ $< -L. -luci
@@ -36,10 +37,10 @@ uci: cli.o libuci.$(SHLIB_EXT)
 uci-static: cli.o libuci.a
        $(CC) $(CFLAGS) -o $@ $^
 
-libuci-static.o: libuci.c file.c uci.h list.c err.h util.c
+libuci-static.o: libuci.c $(LIBUCI_DEPS)
        $(CC) $(CFLAGS) -c -o $@ $<
 
-libuci-shared.o: libuci.c file.c uci.h list.c err.h util.c
+libuci-shared.o: libuci.c $(LIBUCI_DEPS)
        $(CC) $(CFLAGS) $(FPIC) -c -o $@ $<
 
 libuci.a: libuci-static.o
@@ -48,8 +49,17 @@ libuci.a: libuci-static.o
        $(RANLIB) $@
 
 libuci.$(SHLIB_EXT): libuci-shared.o
-       $(LD) $(SHLIB_FLAGS) -o $(SHLIB_FILE) $^ $(LIBS)
+       $(LINK) $(SHLIB_FLAGS) -o $(SHLIB_FILE) $^ $(LIBS)
        ln -sf $(SHLIB_FILE) $@
 
 clean:
-       rm -f uci uci-static *.[oa] *.so* *.dylib*
+       rm -f uci uci-static *.[oa] *.so* *.dylib* uci_config.h
+
+install: all
+       $(INSTALL) -m0644 libuci.a $(DESTDIR)$(prefix)/lib/
+       $(INSTALL) -m0755 $(SHLIB_FILE) $(DESTDIR)$(prefix)/lib/
+       ln -sf $(SHLIB_FILE) $(DESTDIR)$(prefix)/lib/libuci.$(SHLIB_EXT)
+       $(INSTALL) -m0755 uci $(DESTDIR)/usr/bin/
+
+FORCE: ;
+.PHONY: FORCE