remove some obsolete variables. thx, lorenz
[project/uci.git] / Makefile
index 01063a8..c32626d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,8 @@
-COPTS=-g -O2
+COPTS=-O2
 CFLAGS=$(COPTS) -fPIC -Wall -pedantic -std=gnu99 -Wno-unused -Werror
+ifneq ($(DEBUG),)
+  CFLAGS += -g3 -DDEBUG_ALL
+endif
 
 AR=ar
 CC=gcc