split warning options from other compiler options
[project/uci.git] / Makefile
index ecfa8bc..bcd5676 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,8 @@
 COPTS=-O2
-CFLAGS=$(COPTS) -fPIC -Wall -pedantic -std=gnu99 -Wno-unused -Werror
+WOPTS=-pedantic -Wno-unused -Werror
+CFLAGS=$(COPTS) -fPIC -Wall -std=gnu99
 ifneq ($(DEBUG),)
+  COPTS = -O0
   CFLAGS += -g3 -DDEBUG_ALL
 endif