remove unused variables
[project/uci.git] / Makefile
index c32626d..bcd5676 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,8 @@
 COPTS=-O2
-CFLAGS=$(COPTS) -fPIC -Wall -pedantic -std=gnu99 -Wno-unused -Werror
+WOPTS=-pedantic -Wno-unused -Werror
+CFLAGS=$(COPTS) -fPIC -Wall -std=gnu99
 ifneq ($(DEBUG),)
+  COPTS = -O0
   CFLAGS += -g3 -DDEBUG_ALL
 endif
 
@@ -14,7 +16,7 @@ cli.o: cli.c uci.h
 uci: cli.o libuci.a
        $(CC) $(CFLAGS) -o $@ $^
 
-libuci.o: libuci.c file.c uci.h list.c err.h
+libuci.o: libuci.c file.c uci.h list.c err.h util.c
 libuci.a: libuci.o
        rm -f $@
        $(AR) rc $@ $^