split warning options from other compiler options
[project/uci.git] / Makefile
index c136915..bcd5676 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,6 @@
 COPTS=-O2
-CFLAGS=$(COPTS) -fPIC -Wall -pedantic -std=gnu99 -Wno-unused -Werror
+WOPTS=-pedantic -Wno-unused -Werror
+CFLAGS=$(COPTS) -fPIC -Wall -std=gnu99
 ifneq ($(DEBUG),)
   COPTS = -O0
   CFLAGS += -g3 -DDEBUG_ALL