improved parser
[project/uci.git] / Makefile
index dc304fc..645ec65 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,12 +1,12 @@
 CC=gcc
-CFLAGS=-O2 -Wall -pedantic -std=gnu99 -Wno-unused -Werror
+CFLAGS=-g -O2 -Wall -pedantic -std=gnu99 -Wno-unused -Werror
 
 all: parsetest
 parsetest: libuci.o test.o
        $(CC) $(CFLAGS) -o $@ $^
 
-libuci.o: libuci.c parse.c libuci.h
-test.o: test.c libuci.h
+libuci.o: libuci.c parse.c uci.h list.c err.h
+test.o: test.c uci.h
 
 clean:
        rm -f parsetest *.o