examples: split client/server code
authorFelix Fietkau <nbd@openwrt.org>
Mon, 1 Oct 2012 13:03:26 +0000 (15:03 +0200)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 24 Oct 2012 12:37:57 +0000 (14:37 +0200)
.gitignore
examples/CMakeLists.txt
examples/client.c [new file with mode: 0644]
examples/server.c [new file with mode: 0644]
examples/ubus-example.c [deleted file]

index 6eca9d9..551b024 100644 (file)
@@ -5,7 +5,8 @@ CMakeFiles
 *.a
 *.so
 *.dylib
-ubus-example
+examples/server
+examples/client
 ubusd
 ubus
 install_manifest.txt
index 59ba6ab..a6ab7bf 100644 (file)
@@ -1,6 +1,10 @@
 cmake_minimum_required(VERSION 2.6)
 
 ADD_DEFINITIONS(-I..)
-ADD_EXECUTABLE(ubus-example ubus-example.c)
-TARGET_LINK_LIBRARIES(ubus-example ubus ubox)
+
+ADD_EXECUTABLE(server server.c)
+TARGET_LINK_LIBRARIES(server ubus ubox)
+
+ADD_EXECUTABLE(client client.c)
+TARGET_LINK_LIBRARIES(client ubus ubox)
 
diff --git a/examples/client.c b/examples/client.c
new file mode 100644 (file)
index 0000000..315a8e3
--- /dev/null
@@ -0,0 +1,79 @@
+/*
+ * Copyright (C) 2011 Felix Fietkau <nbd@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU Lesser General Public License version 2.1
+ * as published by the Free Software Foundation
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ */
+
+#include <unistd.h>
+
+#include "libubus.h"
+
+static struct ubus_context *ctx;
+static struct blob_buf b;
+
+static struct ubus_object test_client_object = {};
+
+static void client_main(void)
+{
+       uint32_t id;
+       int ret;
+
+       ret = ubus_add_object(ctx, &test_client_object);
+       if (ret) {
+               fprintf(stderr, "Failed to add_object object: %s\n", ubus_strerror(ret));
+               return;
+       }
+
+       if (ubus_lookup_id(ctx, "test", &id)) {
+               fprintf(stderr, "Failed to look up test object\n");
+               return;
+       }
+
+       blob_buf_init(&b, 0);
+       blobmsg_add_u32(&b, "id", test_client_object.id);
+       ubus_invoke(ctx, id, "watch", b.head, NULL, 0, 3000);
+       uloop_run();
+}
+
+int main(int argc, char **argv)
+{
+       const char *ubus_socket = NULL;
+       int ch;
+
+       while ((ch = getopt(argc, argv, "cs:")) != -1) {
+               switch (ch) {
+               case 's':
+                       ubus_socket = optarg;
+                       break;
+               default:
+                       break;
+               }
+       }
+
+       argc -= optind;
+       argv += optind;
+
+       uloop_init();
+
+       ctx = ubus_connect(ubus_socket);
+       if (!ctx) {
+               fprintf(stderr, "Failed to connect to ubus\n");
+               return -1;
+       }
+
+       ubus_add_uloop(ctx);
+
+       client_main();
+
+       ubus_free(ctx);
+       uloop_done();
+
+       return 0;
+}
diff --git a/examples/server.c b/examples/server.c
new file mode 100644 (file)
index 0000000..97789d5
--- /dev/null
@@ -0,0 +1,169 @@
+/*
+ * Copyright (C) 2011 Felix Fietkau <nbd@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU Lesser General Public License version 2.1
+ * as published by the Free Software Foundation
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ */
+
+#include <unistd.h>
+
+#include "libubus.h"
+
+static struct ubus_context *ctx;
+static struct ubus_watch_object test_event;
+static struct blob_buf b;
+
+enum {
+       HELLO_ID,
+       HELLO_MSG,
+       __HELLO_MAX
+};
+
+static const struct blobmsg_policy hello_policy[] = {
+       [HELLO_ID] = { .name = "id", .type = BLOBMSG_TYPE_INT32 },
+       [HELLO_MSG] = { .name = "msg", .type = BLOBMSG_TYPE_STRING },
+};
+
+struct hello_request {
+       struct ubus_request_data req;
+       struct uloop_timeout timeout;
+       char data[];
+};
+
+static void test_hello_reply(struct uloop_timeout *t)
+{
+       struct hello_request *req = container_of(t, struct hello_request, timeout);
+
+       blob_buf_init(&b, 0);
+       blobmsg_add_string(&b, "message", req->data);
+       ubus_send_reply(ctx, &req->req, b.head);
+       ubus_complete_deferred_request(ctx, &req->req, 0);
+       free(req);
+}
+
+static int test_hello(struct ubus_context *ctx, struct ubus_object *obj,
+                     struct ubus_request_data *req, const char *method,
+                     struct blob_attr *msg)
+{
+       struct hello_request *hreq;
+       struct blob_attr *tb[__HELLO_MAX];
+       const char *format = "%s received a message: %s";
+       const char *msgstr = "(unknown)";
+
+       blobmsg_parse(hello_policy, ARRAY_SIZE(hello_policy), tb, blob_data(msg), blob_len(msg));
+
+       if (tb[HELLO_MSG])
+               msgstr = blobmsg_data(tb[HELLO_MSG]);
+
+       hreq = calloc(1, sizeof(*hreq) + strlen(format) + strlen(obj->name) + strlen(msgstr) + 1);
+       sprintf(hreq->data, format, obj->name, msgstr);
+       ubus_defer_request(ctx, req, &hreq->req);
+       hreq->timeout.cb = test_hello_reply;
+       uloop_timeout_set(&hreq->timeout, 1000);
+
+       return 0;
+}
+
+enum {
+       WATCH_ID,
+       __WATCH_MAX
+};
+
+static const struct blobmsg_policy watch_policy[__WATCH_MAX] = {
+       [WATCH_ID] = { .name = "id", .type = BLOBMSG_TYPE_INT32 },
+};
+
+static void test_handle_event(struct ubus_context *ctx, struct ubus_watch_object *w,
+                       uint32_t id)
+{
+       fprintf(stderr, "Object %08x went away\n", id);
+}
+
+static int test_watch(struct ubus_context *ctx, struct ubus_object *obj,
+                     struct ubus_request_data *req, const char *method,
+                     struct blob_attr *msg)
+{
+       struct blob_attr *tb[__WATCH_MAX];
+       int ret;
+
+       blobmsg_parse(watch_policy, __WATCH_MAX, tb, blob_data(msg), blob_len(msg));
+       if (!tb[WATCH_ID])
+               return UBUS_STATUS_INVALID_ARGUMENT;
+
+       test_event.cb = test_handle_event;
+       ret = ubus_watch_object_add(ctx, &test_event, blobmsg_get_u32(tb[WATCH_ID]));
+       fprintf(stderr, "Watching object %08x: %s\n", blobmsg_get_u32(tb[WATCH_ID]), ubus_strerror(ret));
+       return ret;
+}
+
+static const struct ubus_method test_methods[] = {
+       UBUS_METHOD("hello", test_hello, hello_policy),
+       UBUS_METHOD("watch", test_watch, watch_policy),
+};
+
+static struct ubus_object_type test_object_type =
+       UBUS_OBJECT_TYPE("test", test_methods);
+
+static struct ubus_object test_object = {
+       .name = "test",
+       .type = &test_object_type,
+       .methods = test_methods,
+       .n_methods = ARRAY_SIZE(test_methods),
+};
+
+static void server_main(void)
+{
+       int ret;
+
+       ret = ubus_add_object(ctx, &test_object);
+       if (ret)
+               fprintf(stderr, "Failed to add object: %s\n", ubus_strerror(ret));
+
+       ret = ubus_register_watch_object(ctx, &test_event);
+       if (ret)
+               fprintf(stderr, "Failed to add watch handler: %s\n", ubus_strerror(ret));
+
+       uloop_run();
+}
+
+int main(int argc, char **argv)
+{
+       const char *ubus_socket = NULL;
+       int ch;
+
+       while ((ch = getopt(argc, argv, "cs:")) != -1) {
+               switch (ch) {
+               case 's':
+                       ubus_socket = optarg;
+                       break;
+               default:
+                       break;
+               }
+       }
+
+       argc -= optind;
+       argv += optind;
+
+       uloop_init();
+
+       ctx = ubus_connect(ubus_socket);
+       if (!ctx) {
+               fprintf(stderr, "Failed to connect to ubus\n");
+               return -1;
+       }
+
+       ubus_add_uloop(ctx);
+
+       server_main();
+
+       ubus_free(ctx);
+       uloop_done();
+
+       return 0;
+}
diff --git a/examples/ubus-example.c b/examples/ubus-example.c
deleted file mode 100644 (file)
index a7df06f..0000000
+++ /dev/null
@@ -1,204 +0,0 @@
-/*
- * Copyright (C) 2011 Felix Fietkau <nbd@openwrt.org>
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU Lesser General Public License version 2.1
- * as published by the Free Software Foundation
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- */
-
-#include <unistd.h>
-
-#include "libubus.h"
-
-static struct ubus_context *ctx;
-static struct ubus_watch_object test_event;
-static struct blob_buf b;
-
-enum {
-       HELLO_ID,
-       HELLO_MSG,
-       __HELLO_MAX
-};
-
-static const struct blobmsg_policy hello_policy[] = {
-       [HELLO_ID] = { .name = "id", .type = BLOBMSG_TYPE_INT32 },
-       [HELLO_MSG] = { .name = "msg", .type = BLOBMSG_TYPE_STRING },
-};
-
-struct hello_request {
-       struct ubus_request_data req;
-       struct uloop_timeout timeout;
-       char data[];
-};
-
-static void test_hello_reply(struct uloop_timeout *t)
-{
-       struct hello_request *req = container_of(t, struct hello_request, timeout);
-
-       blob_buf_init(&b, 0);
-       blobmsg_add_string(&b, "message", req->data);
-       ubus_send_reply(ctx, &req->req, b.head);
-       ubus_complete_deferred_request(ctx, &req->req, 0);
-       free(req);
-}
-
-static int test_hello(struct ubus_context *ctx, struct ubus_object *obj,
-                     struct ubus_request_data *req, const char *method,
-                     struct blob_attr *msg)
-{
-       struct hello_request *hreq;
-       struct blob_attr *tb[__HELLO_MAX];
-       const char *format = "%s received a message: %s";
-       const char *msgstr = "(unknown)";
-
-       blobmsg_parse(hello_policy, ARRAY_SIZE(hello_policy), tb, blob_data(msg), blob_len(msg));
-
-       if (tb[HELLO_MSG])
-               msgstr = blobmsg_data(tb[HELLO_MSG]);
-
-       hreq = calloc(1, sizeof(*hreq) + strlen(format) + strlen(obj->name) + strlen(msgstr) + 1);
-       sprintf(hreq->data, format, obj->name, msgstr);
-       ubus_defer_request(ctx, req, &hreq->req);
-       hreq->timeout.cb = test_hello_reply;
-       uloop_timeout_set(&hreq->timeout, 1000);
-
-       return 0;
-}
-
-enum {
-       WATCH_ID,
-       __WATCH_MAX
-};
-
-static const struct blobmsg_policy watch_policy[__WATCH_MAX] = {
-       [WATCH_ID] = { .name = "id", .type = BLOBMSG_TYPE_INT32 },
-};
-
-static void test_handle_event(struct ubus_context *ctx, struct ubus_watch_object *w,
-                       uint32_t id)
-{
-       fprintf(stderr, "Object %08x went away\n", id);
-}
-
-static int test_watch(struct ubus_context *ctx, struct ubus_object *obj,
-                     struct ubus_request_data *req, const char *method,
-                     struct blob_attr *msg)
-{
-       struct blob_attr *tb[__WATCH_MAX];
-       int ret;
-
-       blobmsg_parse(watch_policy, __WATCH_MAX, tb, blob_data(msg), blob_len(msg));
-       if (!tb[WATCH_ID])
-               return UBUS_STATUS_INVALID_ARGUMENT;
-
-       test_event.cb = test_handle_event;
-       ret = ubus_watch_object_add(ctx, &test_event, blobmsg_get_u32(tb[WATCH_ID]));
-       fprintf(stderr, "Watching object %08x: %s\n", blobmsg_get_u32(tb[WATCH_ID]), ubus_strerror(ret));
-       return ret;
-}
-
-static const struct ubus_method test_methods[] = {
-       UBUS_METHOD("hello", test_hello, hello_policy),
-       UBUS_METHOD("watch", test_watch, watch_policy),
-};
-
-static struct ubus_object_type test_object_type =
-       UBUS_OBJECT_TYPE("test", test_methods);
-
-static struct ubus_object test_object = {
-       .name = "test",
-       .type = &test_object_type,
-       .methods = test_methods,
-       .n_methods = ARRAY_SIZE(test_methods),
-};
-
-static struct ubus_object test_client_object = {
-       .type = &test_object_type,
-       .methods = test_methods,
-       .n_methods = ARRAY_SIZE(test_methods),
-};
-
-static void server_main(void)
-{
-       int ret;
-
-       ret = ubus_add_object(ctx, &test_object);
-       if (ret)
-               fprintf(stderr, "Failed to add object: %s\n", ubus_strerror(ret));
-
-       ret = ubus_register_watch_object(ctx, &test_event);
-       if (ret)
-               fprintf(stderr, "Failed to add watch handler: %s\n", ubus_strerror(ret));
-
-       uloop_run();
-}
-
-static void client_main(void)
-{
-       uint32_t id;
-       int ret;
-
-       ret = ubus_add_object(ctx, &test_client_object);
-       if (ret) {
-               fprintf(stderr, "Failed to add_object object: %s\n", ubus_strerror(ret));
-               return;
-       }
-
-       if (ubus_lookup_id(ctx, test_object.name, &id)) {
-               fprintf(stderr, "Failed to look up test object\n");
-               return;
-       }
-
-       blob_buf_init(&b, 0);
-       blobmsg_add_u32(&b, "id", test_client_object.id);
-       ubus_invoke(ctx, id, "watch", b.head, NULL, 0, 3000);
-       uloop_run();
-}
-
-int main(int argc, char **argv)
-{
-       const char *ubus_socket = NULL;
-       bool client = false;
-       int ch;
-
-       while ((ch = getopt(argc, argv, "cs:")) != -1) {
-               switch (ch) {
-               case 's':
-                       ubus_socket = optarg;
-                       break;
-               case 'c':
-                       client = true;
-                       break;
-               default:
-                       break;
-               }
-       }
-
-       argc -= optind;
-       argv += optind;
-
-       uloop_init();
-
-       ctx = ubus_connect(ubus_socket);
-       if (!ctx) {
-               fprintf(stderr, "Failed to connect to ubus\n");
-               return -1;
-       }
-
-       ubus_add_uloop(ctx);
-
-       if (client)
-               client_main();
-       else
-               server_main();
-
-       ubus_free(ctx);
-       uloop_done();
-
-       return 0;
-}