lua: put LUAPATH in quotes to prevent weird error messages when it is unset
authorFelix Fietkau <nbd@openwrt.org>
Sun, 6 May 2012 08:25:46 +0000 (10:25 +0200)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 6 May 2012 08:25:46 +0000 (10:25 +0200)
lua/CMakeLists.txt

index 6c22bfc..b4fa4d9 100644 (file)
@@ -31,7 +31,7 @@ IF(NOT LUAPATH)
        )
 
        IF(BUILD_LUA)
        )
 
        IF(BUILD_LUA)
-               IF(NOT ${LUA_CHECK_RES} EQUAL 0 OR ${LUAPATH} EQUAL "")
+               IF(NOT ${LUA_CHECK_RES} EQUAL 0 OR "${LUAPATH}" EQUAL "")
                        MESSAGE(SEND_ERROR "Lua was not found on your system")
                ENDIF()
        ENDIF()
                        MESSAGE(SEND_ERROR "Lua was not found on your system")
                ENDIF()
        ENDIF()