libubus: do not register/unregister with uloop during sync requests
[project/ubus.git] / examples / CMakeLists.txt
index a6ab7bf..81f9997 100644 (file)
@@ -1,10 +1,12 @@
 cmake_minimum_required(VERSION 2.6)
 
 ADD_DEFINITIONS(-I..)
+INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/..)
 
-ADD_EXECUTABLE(server server.c)
-TARGET_LINK_LIBRARIES(server ubus ubox)
-
-ADD_EXECUTABLE(client client.c)
-TARGET_LINK_LIBRARIES(client ubus ubox)
+IF (BUILD_EXAMPLES)
+       ADD_EXECUTABLE(server server.c count.c)
+       TARGET_LINK_LIBRARIES(server ubus ${ubox_library} ${blob_library} ${json})
 
+       ADD_EXECUTABLE(client client.c count.c)
+       TARGET_LINK_LIBRARIES(client ubus ${ubox_library})
+ENDIF()