ubus/lua: pass notification name to callback
[project/ubus.git] / examples / CMakeLists.txt
index 3d06161..81f9997 100644 (file)
@@ -4,9 +4,9 @@ ADD_DEFINITIONS(-I..)
 INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/..)
 
 IF (BUILD_EXAMPLES)
-       ADD_EXECUTABLE(server server.c)
-       TARGET_LINK_LIBRARIES(server ubus ubox blobmsg_json)
+       ADD_EXECUTABLE(server server.c count.c)
+       TARGET_LINK_LIBRARIES(server ubus ${ubox_library} ${blob_library} ${json})
 
-       ADD_EXECUTABLE(client client.c)
-       TARGET_LINK_LIBRARIES(client ubus ubox)
+       ADD_EXECUTABLE(client client.c count.c)
+       TARGET_LINK_LIBRARIES(client ubus ${ubox_library})
 ENDIF()