Link json-c
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 1 Sep 2013 20:12:19 +0000 (22:12 +0200)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 1 Sep 2013 20:22:42 +0000 (22:22 +0200)
CMakeLists.txt

index 8ac4643..e9f1586 100644 (file)
@@ -11,7 +11,10 @@ IF(APPLE)
 ENDIF()
 
 ADD_EXECUTABLE(luci-rpcd main.c exec.c session.c file.c uci.c iwinfo.c luci2.c plugin.c)
-TARGET_LINK_LIBRARIES(luci-rpcd ubox ubus uci iwinfo blobmsg_json)
+
+FIND_LIBRARY(json NAMES json-c json)
+
+TARGET_LINK_LIBRARIES(luci-rpcd ubox ubus uci iwinfo blobmsg_json ${json})
 
 SET(CMAKE_INSTALL_PREFIX /usr)