Rename from "luci-rpcd" to "rpcd"
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 2 Sep 2013 15:09:57 +0000 (17:09 +0200)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 2 Sep 2013 15:23:30 +0000 (17:23 +0200)
16 files changed:
CMakeLists.txt
exec.c
exec.h
file.c
file.h
iwinfo.c
iwinfo.h
luci2.c
luci2.h
main.c
plugin.c
plugin.h
session.c
session.h
uci.c
uci.h

index 6f42902..f448a72 100644 (file)
@@ -1,6 +1,6 @@
 cmake_minimum_required(VERSION 2.6)
 
-PROJECT(luci-rpcd C)
+PROJECT(rpcd C)
 ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations)
 
 OPTION(FILE_SUPPORT "File plugin support" ON)
@@ -16,8 +16,8 @@ ENDIF()
 
 FIND_LIBRARY(json NAMES json-c json)
 
-ADD_EXECUTABLE(luci-rpcd main.c exec.c session.c uci.c plugin.c)
-TARGET_LINK_LIBRARIES(luci-rpcd ubox ubus uci dl blobmsg_json ${json})
+ADD_EXECUTABLE(rpcd main.c exec.c session.c uci.c plugin.c)
+TARGET_LINK_LIBRARIES(rpcd ubox ubus uci dl blobmsg_json ${json})
 
 SET(PLUGINS "")
 
@@ -42,7 +42,7 @@ IF (IWINFO_SUPPORT)
   SET_TARGET_PROPERTIES(iwinfo_plugin PROPERTIES OUTPUT_NAME iwinfo PREFIX "")
 ENDIF()
 
-INSTALL(TARGETS luci-rpcd ${PLUGINS}
+INSTALL(TARGETS rpcd ${PLUGINS}
        RUNTIME DESTINATION sbin
        LIBRARY DESTINATION lib
 )
diff --git a/exec.c b/exec.c
index 944ade4..c03e450 100644 (file)
--- a/exec.c
+++ b/exec.c
@@ -1,5 +1,5 @@
 /*
- * luci-rpcd - LuCI UBUS RPC server
+ * rpcd - UBUS RPC server
  *
  *   Copyright (C) 2013 Jo-Philipp Wich <jow@openwrt.org>
  *
diff --git a/exec.h b/exec.h
index 8642c0b..05ba3ca 100644 (file)
--- a/exec.h
+++ b/exec.h
@@ -1,5 +1,5 @@
 /*
- * luci-rpcd - LuCI UBUS RPC server
+ * rpcd - UBUS RPC server
  *
  *   Copyright (C) 2013 Jo-Philipp Wich <jow@openwrt.org>
  *
diff --git a/file.c b/file.c
index 2d33272..0e8df4f 100644 (file)
--- a/file.c
+++ b/file.c
@@ -1,5 +1,5 @@
 /*
- * luci-rpcd - LuCI UBUS RPC server
+ * rpcd - UBUS RPC server
  *
  *   Copyright (C) 2013 Jo-Philipp Wich <jow@openwrt.org>
  *
diff --git a/file.h b/file.h
index 870e267..0cd2592 100644 (file)
--- a/file.h
+++ b/file.h
@@ -1,5 +1,5 @@
 /*
- * luci-rpcd - LuCI UBUS RPC server
+ * rpcd - UBUS RPC server
  *
  *   Copyright (C) 2013 Jo-Philipp Wich <jow@openwrt.org>
  *
index 893da01..b78a335 100644 (file)
--- a/iwinfo.c
+++ b/iwinfo.c
@@ -1,5 +1,5 @@
 /*
- * luci-rpcd - LuCI UBUS RPC server
+ * rpcd - UBUS RPC server
  *
  *   Copyright (C) 2013 Jo-Philipp Wich <jow@openwrt.org>
  *
index bc1a8bb..29ecf9f 100644 (file)
--- a/iwinfo.h
+++ b/iwinfo.h
@@ -1,5 +1,5 @@
 /*
- * luci-rpcd - LuCI UBUS RPC server
+ * rpcd - UBUS RPC server
  *
  *   Copyright (C) 2013 Jo-Philipp Wich <jow@openwrt.org>
  *
diff --git a/luci2.c b/luci2.c
index bb68a4b..27eead5 100644 (file)
--- a/luci2.c
+++ b/luci2.c
@@ -1,5 +1,5 @@
 /*
- * luci-rpcd - LuCI UBUS RPC server
+ * rpcd - UBUS RPC server
  *
  *   Copyright (C) 2013 Jo-Philipp Wich <jow@openwrt.org>
  *
diff --git a/luci2.h b/luci2.h
index 480c973..41c8321 100644 (file)
--- a/luci2.h
+++ b/luci2.h
@@ -1,5 +1,5 @@
 /*
- * luci-rpcd - LuCI UBUS RPC server
+ * rpcd - UBUS RPC server
  *
  *   Copyright (C) 2013 Jo-Philipp Wich <jow@openwrt.org>
  *
diff --git a/main.c b/main.c
index 5f5c17f..efaa114 100644 (file)
--- a/main.c
+++ b/main.c
@@ -1,5 +1,5 @@
 /*
- * luci-rpcd - LuCI UBUS RPC server
+ * rpcd - UBUS RPC server
  *
  *   Copyright (C) 2013 Felix Fietkau <nbd@openwrt.org>
  *   Copyright (C) 2013 Jo-Philipp Wich <jow@openwrt.org>
index 56260e2..33266b3 100644 (file)
--- a/plugin.c
+++ b/plugin.c
@@ -1,5 +1,5 @@
 /*
- * luci-rpcd - LuCI UBUS RPC server
+ * rpcd - UBUS RPC server
  *
  *   Copyright (C) 2013 Jo-Philipp Wich <jow@openwrt.org>
  *
index 6064b68..0d10f09 100644 (file)
--- a/plugin.h
+++ b/plugin.h
@@ -1,5 +1,5 @@
 /*
- * luci-rpcd - LuCI UBUS RPC server
+ * rpcd - UBUS RPC server
  *
  *   Copyright (C) 2013 Jo-Philipp Wich <jow@openwrt.org>
  *
 #include "session.h"
 
 /* location of plugin executables */
-#define RPC_PLUGIN_DIRECTORY        "/usr/libexec/luci-rpcd"
+#define RPC_PLUGIN_DIRECTORY        "/usr/libexec/rpcd"
 
 /* location of plugin libraries */
-#define RPC_LIBRARY_DIRECTORY       "/usr/lib/luci-rpcd"
+#define RPC_LIBRARY_DIRECTORY       "/usr/lib/rpcd"
 
 struct rpc_daemon_ops {
     bool (*access)(const char *sid, const char *scope,
index b43e763..d970d45 100644 (file)
--- a/session.c
+++ b/session.c
@@ -1,5 +1,5 @@
 /*
- * luci-rpcd - LuCI UBUS RPC server
+ * rpcd - UBUS RPC server
  *
  *   Copyright (C) 2013 Felix Fietkau <nbd@openwrt.org>
  *   Copyright (C) 2013 Jo-Philipp Wich <jow@openwrt.org>
index 3f50e77..bcdcb96 100644 (file)
--- a/session.h
+++ b/session.h
@@ -1,5 +1,5 @@
 /*
- * luci-rpcd - LuCI UBUS RPC server
+ * rpcd - UBUS RPC server
  *
  *   Copyright (C) 2013 Felix Fietkau <nbd@openwrt.org>
  *   Copyright (C) 2013 Jo-Philipp Wich <jow@openwrt.org>
diff --git a/uci.c b/uci.c
index ac97cbd..aba897e 100644 (file)
--- a/uci.c
+++ b/uci.c
@@ -1,5 +1,5 @@
 /*
- * luci-rpcd - LuCI UBUS RPC server
+ * rpcd - UBUS RPC server
  *
  *   Copyright (C) 2013 Jo-Philipp Wich <jow@openwrt.org>
  *
diff --git a/uci.h b/uci.h
index cf0faa1..aa1e797 100644 (file)
--- a/uci.h
+++ b/uci.h
@@ -1,5 +1,5 @@
 /*
- * luci-rpcd - LuCI UBUS RPC server
+ * rpcd - UBUS RPC server
  *
  *   Copyright (C) 2013 Jo-Philipp Wich <jow@openwrt.org>
  *