Link json-c
[project/rpcd.git] / CMakeLists.txt
index 3c34700..e9f1586 100644 (file)
@@ -10,8 +10,11 @@ IF(APPLE)
   LINK_DIRECTORIES(/opt/local/lib)
 ENDIF()
 
-ADD_EXECUTABLE(luci-rpcd main.c session.c file.c uci.c iwinfo.c)
-TARGET_LINK_LIBRARIES(luci-rpcd ubox ubus uci iwinfo)
+ADD_EXECUTABLE(luci-rpcd main.c exec.c session.c file.c uci.c iwinfo.c luci2.c plugin.c)
+
+FIND_LIBRARY(json NAMES json-c json)
+
+TARGET_LINK_LIBRARIES(luci-rpcd ubox ubus uci iwinfo blobmsg_json ${json})
 
 SET(CMAKE_INSTALL_PREFIX /usr)