Rework plugin support to use incremental json parsing and rpc_exec() framework for...
[project/rpcd.git] / CMakeLists.txt
index 14289b7..8ac4643 100644 (file)
@@ -10,8 +10,8 @@ IF(APPLE)
   LINK_DIRECTORIES(/opt/local/lib)
 ENDIF()
 
-ADD_EXECUTABLE(luci-rpcd main.c exec.c session.c file.c uci.c iwinfo.c luci2.c)
-TARGET_LINK_LIBRARIES(luci-rpcd ubox ubus uci iwinfo)
+ADD_EXECUTABLE(luci-rpcd main.c exec.c session.c file.c uci.c iwinfo.c luci2.c plugin.c)
+TARGET_LINK_LIBRARIES(luci-rpcd ubox ubus uci iwinfo blobmsg_json)
 
 SET(CMAKE_INSTALL_PREFIX /usr)