add ubus iwinfo api (lacks scanning, assoclist, countrylist and txpowerlist yet)
[project/rpcd.git] / CMakeLists.txt
index eef3856..3c34700 100644 (file)
@@ -10,8 +10,8 @@ IF(APPLE)
   LINK_DIRECTORIES(/opt/local/lib)
 ENDIF()
 
-ADD_EXECUTABLE(luci-rpcd main.c session.c file.c)
-TARGET_LINK_LIBRARIES(luci-rpcd ubox ubus)
+ADD_EXECUTABLE(luci-rpcd main.c session.c file.c uci.c iwinfo.c)
+TARGET_LINK_LIBRARIES(luci-rpcd ubox ubus uci iwinfo)
 
 SET(CMAKE_INSTALL_PREFIX /usr)