Cancel pending timeouts before freeing hosts
[project/relayd.git] / Makefile
index cc8f76f..1715881 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -4,11 +4,13 @@ LDFLAGS =
 
 all: relayd 
 
-relayd: uloop.o main.o
+relayd: uloop.o main.o route.o
        $(CC) -o $@ $^ $(LDFLAGS)
 
+relayd.h: list.h
 uloop.c: uloop.h
-main.c: uloop.h
+main.c: uloop.h relayd.h
+route.c: relayd.h
 
 %.o: %.c
        $(CC) -c $(CPPFLAGS) $(CFLAGS) -o $@ $^