Cancel pending timeouts before freeing hosts
[project/relayd.git] / Makefile
index 74ff810..1715881 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,13 +1,16 @@
-CFLAGS = -O2 -Wall -Werror -pedantic --std=gnu99
+CFLAGS = -Os -Wall -Werror -pedantic --std=gnu99
 CPPFLAGS = -I.
+LDFLAGS =
 
 all: relayd 
 
-relayd: uloop.o main.o
-       $(CC) -o $@ $^
+relayd: uloop.o main.o route.o
+       $(CC) -o $@ $^ $(LDFLAGS)
 
+relayd.h: list.h
 uloop.c: uloop.h
-main.c: uloop.h
+main.c: uloop.h relayd.h
+route.c: relayd.h
 
 %.o: %.c
        $(CC) -c $(CPPFLAGS) $(CFLAGS) -o $@ $^