procd: force -lc -lgcc to handle cross-dependencies between those two
authorFelix Fietkau <nbd@openwrt.org>
Wed, 11 Jun 2014 17:48:16 +0000 (19:48 +0200)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 11 Jun 2014 17:48:16 +0000 (19:48 +0200)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
CMakeLists.txt

index 2b72ad3..b90cdd7 100644 (file)
@@ -43,7 +43,7 @@ INSTALL(TARGETS udevtrigger
 
 
 ADD_EXECUTABLE(upgraded upgraded.c watchdog.c)
-TARGET_LINK_LIBRARIES(upgraded ubox.a rt.a -static)
+TARGET_LINK_LIBRARIES(upgraded ubox.a rt.a -static -lc -lgcc)
 set_target_properties(upgraded PROPERTIES LINK_SEARCH_END_STATIC 1)
 INSTALL(TARGETS upgraded
        RUNTIME DESTINATION sbin