add blobmsg list helpers
authorFelix Fietkau <nbd@openwrt.org>
Sun, 10 Jun 2012 14:47:16 +0000 (16:47 +0200)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 10 Jun 2012 14:47:16 +0000 (16:47 +0200)
CMakeLists.txt
utils.c [new file with mode: 0644]
utils.h [new file with mode: 0644]

index a903ac8..aaa3982 100644 (file)
@@ -10,7 +10,7 @@ IF(APPLE)
   LINK_DIRECTORIES(/opt/local/lib)
 ENDIF()
 
-SET(SOURCES main.c ubus.c service.c instance.c)
+SET(SOURCES main.c ubus.c service.c instance.c utils.c)
 
 SET(LIBS ubox ubus)
 
diff --git a/utils.c b/utils.c
new file mode 100644 (file)
index 0000000..cff67bd
--- /dev/null
+++ b/utils.c
@@ -0,0 +1,55 @@
+#include <libubox/avl.h>
+#include <libubox/avl-cmp.h>
+#include "utils.h"
+
+void
+__blobmsg_list_init(struct blobmsg_list *list, int offset, int len)
+{
+       avl_init(&list->avl, avl_strcmp, false, NULL);
+       list->node_offset = offset;
+       list->node_len = len;
+}
+
+int
+blobmsg_list_fill(struct blobmsg_list *list, void *data, int len)
+{
+       struct avl_tree *tree = &list->avl;
+       struct blobmsg_list_node *node;
+       struct blob_attr *cur;
+       void *ptr;
+       int count = 0;
+       int rem = len;
+
+       __blob_for_each_attr(cur, data, rem) {
+               if (!blobmsg_check_attr(cur, true))
+                       continue;
+
+               ptr = calloc(1, list->node_len);
+               if (!ptr)
+                       return -1;
+
+               node = (void *) ((char *)ptr + list->node_offset);
+               node->avl.key = blobmsg_name(cur);
+               node->data = cur;
+               if (avl_insert(tree, &node->avl)) {
+                       free(ptr);
+                       continue;
+               }
+
+               count++;
+       }
+
+       return count;
+}
+
+void
+blobmsg_list_free(struct blobmsg_list *list)
+{
+       struct blobmsg_list_node *node, *tmp;
+       void *ptr;
+
+       avl_remove_all_elements(&list->avl, node, avl, tmp) {
+               ptr = ((char *) node - list->node_offset);
+               free(ptr);
+       }
+}
diff --git a/utils.h b/utils.h
new file mode 100644 (file)
index 0000000..3aad3b1
--- /dev/null
+++ b/utils.h
@@ -0,0 +1,26 @@
+#ifndef __PROCD_UTILS_H
+#define __PROCD_UTILS_H
+
+#include <libubox/avl.h>
+#include <libubox/blob.h>
+#include <libubox/blobmsg.h>
+
+struct blobmsg_list {
+       struct avl_tree avl;
+       int node_offset;
+       int node_len;
+};
+
+struct blobmsg_list_node {
+       struct avl_node avl;
+       struct blob_attr *data;
+};
+
+#define blobmsg_list_init(list, type, field) \
+       __blobmsg_list_init(tree, offsetof(type, field), sizeof(type))
+
+void __blobmsg_list_init(struct blobmsg_list *list, int offset, int len);
+int blobmsg_list_fill(struct blobmsg_list *list, void *data, int len);
+void blobmsg_list_free(struct blobmsg_list *list);
+
+#endif