make ue of the md5.c inside libubox
authorJohn Crispin <blogic@openwrt.org>
Tue, 19 Nov 2013 19:55:54 +0000 (20:55 +0100)
committerJohn Crispin <blogic@openwrt.org>
Tue, 19 Nov 2013 19:56:13 +0000 (20:56 +0100)
Signed-off-by: John Crispin <blogic@openwrt.org>
CMakeLists.txt
service/instance.c
utils/md5.c [deleted file]
utils/md5.h [deleted file]

index d353801..c50b05d 100644 (file)
@@ -12,7 +12,7 @@ ENDIF()
 
 SET(SOURCES procd.c signal.c watchdog.c state.c        inittab.c rcS.c ubus.c system.c
        service/service.c service/instance.c service/validate.c service/trigger.c
 
 SET(SOURCES procd.c signal.c watchdog.c state.c        inittab.c rcS.c ubus.c system.c
        service/service.c service/instance.c service/validate.c service/trigger.c
-       plug/coldplug.c plug/hotplug.c utils/utils.c utils/md5.c)
+       plug/coldplug.c plug/hotplug.c utils/utils.c)
 
 find_library(json NAMES json-c json)
 SET(LIBS ubox ubus ${json} blobmsg_json json_script)
 
 find_library(json NAMES json-c json)
 SET(LIBS ubox ubus ${json} blobmsg_json json_script)
index ab517d7..20017ce 100644 (file)
 #include <stdint.h>
 #include <fcntl.h>
 
 #include <stdint.h>
 #include <fcntl.h>
 
+#include <libubox/md5.h>
+
 #include "../procd.h"
 
 #include "service.h"
 #include "instance.h"
 
 #include "../procd.h"
 
 #include "service.h"
 #include "instance.h"
 
-#include "../utils/md5.h"
 
 enum {
        INSTANCE_ATTR_COMMAND,
 
 enum {
        INSTANCE_ATTR_COMMAND,
diff --git a/utils/md5.c b/utils/md5.c
deleted file mode 100644 (file)
index ec24dd2..0000000
+++ /dev/null
@@ -1,242 +0,0 @@
-/*
- *  md5.c - Compute MD5 checksum of strings according to the
- *          definition of MD5 in RFC 1321 from April 1992.
- *
- *  Written by Ulrich Drepper <drepper@gnu.ai.mit.edu>, 1995.
- *
- *  Copyright (C) 1995-1999 Free Software Foundation, Inc.
- *  Copyright (C) 2001 Manuel Novoa III
- *  Copyright (C) 2003 Glenn L. McGrath
- *  Copyright (C) 2003 Erik Andersen
- *
- *  Licensed under the GPL v2 or later, see the file LICENSE in this tarball.
- */
-
-#include <libubox/blob.h> /* TODO: better include for bswap_32 compat */
-#include "md5.h"
-
-#if __BYTE_ORDER == __LITTLE_ENDIAN
-#define SWAP_LE32(x) (x)
-#else
-#define SWAP_LE32(x) bswap_32(x)
-#endif
-
-/* Initialize structure containing state of computation.
- * (RFC 1321, 3.3: Step 3)
- */
-void md5_begin(md5_ctx_t *ctx)
-{
-       ctx->A = 0x67452301;
-       ctx->B = 0xefcdab89;
-       ctx->C = 0x98badcfe;
-       ctx->D = 0x10325476;
-
-       ctx->total = 0;
-       ctx->buflen = 0;
-}
-
-/* These are the four functions used in the four steps of the MD5 algorithm
- * and defined in the RFC 1321.  The first function is a little bit optimized
- * (as found in Colin Plumbs public domain implementation).
- * #define FF(b, c, d) ((b & c) | (~b & d))
- */
-# define FF(b, c, d) (d ^ (b & (c ^ d)))
-# define FG(b, c, d) FF (d, b, c)
-# define FH(b, c, d) (b ^ c ^ d)
-# define FI(b, c, d) (c ^ (b | ~d))
-
-/* Hash a single block, 64 bytes long and 4-byte aligned. */
-static void md5_hash_block(const void *buffer, md5_ctx_t *ctx)
-{
-       uint32_t correct_words[16];
-       const uint32_t *words = buffer;
-
-       static const uint32_t C_array[] = {
-               /* round 1 */
-               0xd76aa478, 0xe8c7b756, 0x242070db, 0xc1bdceee,
-               0xf57c0faf, 0x4787c62a, 0xa8304613, 0xfd469501,
-               0x698098d8, 0x8b44f7af, 0xffff5bb1, 0x895cd7be,
-               0x6b901122, 0xfd987193, 0xa679438e, 0x49b40821,
-               /* round 2 */
-               0xf61e2562, 0xc040b340, 0x265e5a51, 0xe9b6c7aa,
-               0xd62f105d, 0x2441453, 0xd8a1e681, 0xe7d3fbc8,
-               0x21e1cde6, 0xc33707d6, 0xf4d50d87, 0x455a14ed,
-               0xa9e3e905, 0xfcefa3f8, 0x676f02d9, 0x8d2a4c8a,
-               /* round 3 */
-               0xfffa3942, 0x8771f681, 0x6d9d6122, 0xfde5380c,
-               0xa4beea44, 0x4bdecfa9, 0xf6bb4b60, 0xbebfbc70,
-               0x289b7ec6, 0xeaa127fa, 0xd4ef3085, 0x4881d05,
-               0xd9d4d039, 0xe6db99e5, 0x1fa27cf8, 0xc4ac5665,
-               /* round 4 */
-               0xf4292244, 0x432aff97, 0xab9423a7, 0xfc93a039,
-               0x655b59c3, 0x8f0ccc92, 0xffeff47d, 0x85845dd1,
-               0x6fa87e4f, 0xfe2ce6e0, 0xa3014314, 0x4e0811a1,
-               0xf7537e82, 0xbd3af235, 0x2ad7d2bb, 0xeb86d391
-       };
-
-       static const char P_array[] = {
-               0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15,   /* 1 */
-               1, 6, 11, 0, 5, 10, 15, 4, 9, 14, 3, 8, 13, 2, 7, 12,   /* 2 */
-               5, 8, 11, 14, 1, 4, 7, 10, 13, 0, 3, 6, 9, 12, 15, 2,   /* 3 */
-               0, 7, 14, 5, 12, 3, 10, 1, 8, 15, 6, 13, 4, 11, 2, 9    /* 4 */
-       };
-
-       static const char S_array[] = {
-               7, 12, 17, 22,
-               5, 9, 14, 20,
-               4, 11, 16, 23,
-               6, 10, 15, 21
-       };
-
-       uint32_t A = ctx->A;
-       uint32_t B = ctx->B;
-       uint32_t C = ctx->C;
-       uint32_t D = ctx->D;
-
-       uint32_t *cwp = correct_words;
-
-#  define CYCLIC(w, s) (w = (w << s) | (w >> (32 - s)))
-
-       const uint32_t *pc;
-       const char *pp;
-       const char *ps;
-       int i;
-       uint32_t temp;
-
-       for (i = 0; i < 16; i++) {
-               cwp[i] = SWAP_LE32(words[i]);
-       }
-       words += 16;
-
-       pc = C_array;
-       pp = P_array;
-       ps = S_array;
-
-       for (i = 0; i < 16; i++) {
-               temp = A + FF(B, C, D) + cwp[(int) (*pp++)] + *pc++;
-               CYCLIC(temp, ps[i & 3]);
-               temp += B;
-               A = D;
-               D = C;
-               C = B;
-               B = temp;
-       }
-
-       ps += 4;
-       for (i = 0; i < 16; i++) {
-               temp = A + FG(B, C, D) + cwp[(int) (*pp++)] + *pc++;
-               CYCLIC(temp, ps[i & 3]);
-               temp += B;
-               A = D;
-               D = C;
-               C = B;
-               B = temp;
-       }
-       ps += 4;
-       for (i = 0; i < 16; i++) {
-               temp = A + FH(B, C, D) + cwp[(int) (*pp++)] + *pc++;
-               CYCLIC(temp, ps[i & 3]);
-               temp += B;
-               A = D;
-               D = C;
-               C = B;
-               B = temp;
-       }
-       ps += 4;
-       for (i = 0; i < 16; i++) {
-               temp = A + FI(B, C, D) + cwp[(int) (*pp++)] + *pc++;
-               CYCLIC(temp, ps[i & 3]);
-               temp += B;
-               A = D;
-               D = C;
-               C = B;
-               B = temp;
-       }
-
-
-       ctx->A += A;
-       ctx->B += B;
-       ctx->C += C;
-       ctx->D += D;
-}
-
-/* Feed data through a temporary buffer to call md5_hash_aligned_block()
- * with chunks of data that are 4-byte aligned and a multiple of 64 bytes.
- * This function's internal buffer remembers previous data until it has 64
- * bytes worth to pass on.  Call md5_end() to flush this buffer. */
-
-void md5_hash(const void *buffer, size_t len, md5_ctx_t *ctx)
-{
-       char *buf = (char *)buffer;
-
-       /* RFC 1321 specifies the possible length of the file up to 2^64 bits,
-        * Here we only track the number of bytes.  */
-
-       ctx->total += len;
-
-       // Process all input.
-
-       while (len) {
-               unsigned i = 64 - ctx->buflen;
-
-               // Copy data into aligned buffer.
-
-               if (i > len)
-                       i = len;
-               memcpy(ctx->buffer + ctx->buflen, buf, i);
-               len -= i;
-               ctx->buflen += i;
-               buf += i;
-
-               // When buffer fills up, process it.
-
-               if (ctx->buflen == 64) {
-                       md5_hash_block(ctx->buffer, ctx);
-                       ctx->buflen = 0;
-               }
-       }
-}
-
-/* Process the remaining bytes in the buffer and put result from CTX
- * in first 16 bytes following RESBUF.  The result is always in little
- * endian byte order, so that a byte-wise output yields to the wanted
- * ASCII representation of the message digest.
- *
- * IMPORTANT: On some systems it is required that RESBUF is correctly
- * aligned for a 32 bits value.
- */
-void md5_end(void *resbuf, md5_ctx_t *ctx)
-{
-       char *buf = ctx->buffer;
-       int i;
-
-       /* Pad data to block size.  */
-
-       buf[ctx->buflen++] = 0x80;
-       memset(buf + ctx->buflen, 0, 128 - ctx->buflen);
-
-       /* Put the 64-bit file length in *bits* at the end of the buffer.  */
-       ctx->total <<= 3;
-       if (ctx->buflen > 56)
-               buf += 64;
-
-       for (i = 0; i < 8; i++)
-               buf[56 + i] = ctx->total >> (i*8);
-
-       /* Process last bytes.  */
-       if (buf != ctx->buffer)
-               md5_hash_block(ctx->buffer, ctx);
-       md5_hash_block(buf, ctx);
-
-       /* Put result from CTX in first 16 bytes following RESBUF.  The result is
-        * always in little endian byte order, so that a byte-wise output yields
-        * to the wanted ASCII representation of the message digest.
-        *
-        * IMPORTANT: On some systems it is required that RESBUF is correctly
-        * aligned for a 32 bits value.
-        */
-       ((uint32_t *) resbuf)[0] = SWAP_LE32(ctx->A);
-       ((uint32_t *) resbuf)[1] = SWAP_LE32(ctx->B);
-       ((uint32_t *) resbuf)[2] = SWAP_LE32(ctx->C);
-       ((uint32_t *) resbuf)[3] = SWAP_LE32(ctx->D);
-}
diff --git a/utils/md5.h b/utils/md5.h
deleted file mode 100644 (file)
index e1731ef..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-/*
- * Copyright (C) 2013 Felix Fietkau <nbd@openwrt.org>
- * Copyright (C) 2013 John Crispin <blogic@openwrt.org>
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU Lesser General Public License version 2.1
- * as published by the Free Software Foundation
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- */
-
-#ifndef __PROCD_MD5_H
-#define __PROCD_MD5_H
-
-#include <stdint.h>
-#include <stddef.h>
-
-typedef struct md5_ctx {
-       uint32_t A;
-       uint32_t B;
-       uint32_t C;
-       uint32_t D;
-       uint64_t total;
-       uint32_t buflen;
-       char buffer[128];
-} md5_ctx_t;
-
-void md5_begin(md5_ctx_t *ctx);
-void md5_hash(const void *data, size_t length, md5_ctx_t *ctx);
-void md5_end(void *resbuf, md5_ctx_t *ctx);
-
-#endif