netifd: fixes for json-c 0.12
authorJohn Crispin <blogic@openwrt.org>
Thu, 5 Mar 2015 18:44:31 +0000 (19:44 +0100)
committerSteven Barth <steven@midlink.org>
Fri, 6 Mar 2015 14:25:44 +0000 (15:25 +0100)
Signed-off-by: John Crispin <blogic@openwrt.org>
CMakeLists.txt
handler.h

index e648b03..85527be 100644 (file)
@@ -18,9 +18,8 @@ SET(SOURCES
        macvlan.c ubus.c vlandev.c wireless.c)
 
 
        macvlan.c ubus.c vlandev.c wireless.c)
 
 
-find_library(json NAMES json-c json)
 SET(LIBS
 SET(LIBS
-       ubox ubus uci ${json} blobmsg_json)
+       ubox ubus uci json-c blobmsg_json)
 
 IF (NOT DEFINED LIBNL_LIBS)
   FIND_LIBRARY(libnl NAMES libnl-3 libnl nl-3 nl)
 
 IF (NOT DEFINED LIBNL_LIBS)
   FIND_LIBRARY(libnl NAMES libnl-3 libnl nl-3 nl)
index e96c05a..e3e2af5 100644 (file)
--- a/handler.h
+++ b/handler.h
@@ -15,7 +15,7 @@
 #define __NETIFD_HANDLER_H
 
 #include <libubox/blobmsg_json.h>
 #define __NETIFD_HANDLER_H
 
 #include <libubox/blobmsg_json.h>
-#include <json/json.h>
+#include <json-c/json.h>
 #include "config.h"
 
 typedef void (*script_dump_cb)(const char *script, const char *name, json_object *obj);
 #include "config.h"
 
 typedef void (*script_dump_cb)(const char *script, const char *name, json_object *obj);