wireless: fix blob buf in put_container()
[project/netifd.git] / CMakeLists.txt
index 4ef4dfa..e648b03 100644 (file)
@@ -11,18 +11,20 @@ IF(APPLE)
 ENDIF()
 
 SET(SOURCES
-       main.c utils.c system.c tunnel.c
+       main.c utils.c system.c tunnel.c handler.c
        interface.c interface-ip.c interface-event.c
-       proto.c proto-static.c proto-shell.c
+       iprule.c proto.c proto-static.c proto-shell.c
        config.c device.c bridge.c vlan.c alias.c
-       ubus.c)
+       macvlan.c ubus.c vlandev.c wireless.c)
 
 
+find_library(json NAMES json-c json)
 SET(LIBS
-       ubox ubus uci json blobmsg_json)
+       ubox ubus uci ${json} blobmsg_json)
 
 IF (NOT DEFINED LIBNL_LIBS)
-  SET(LIBNL_LIBS -lnl)
+  FIND_LIBRARY(libnl NAMES libnl-3 libnl nl-3 nl)
+  SET(LIBNL_LIBS ${libnl})
 ENDIF()
 
 IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)
@@ -35,6 +37,9 @@ ENDIF()
 
 IF(DEBUG)
   ADD_DEFINITIONS(-DDEBUG -g3)
+  IF(NO_OPTIMIZE)
+    ADD_DEFINITIONS(-O0)
+  ENDIF()
 ENDIF()