IPv6: fix prefix assignment with continuous hints
[project/netifd.git] / CMakeLists.txt
index 2076fc9..ca201dc 100644 (file)
@@ -13,7 +13,7 @@ ENDIF()
 SET(SOURCES
        main.c utils.c system.c tunnel.c
        interface.c interface-ip.c interface-event.c
-       proto.c proto-static.c proto-shell.c
+       iprule.c proto.c proto-static.c proto-shell.c
        config.c device.c bridge.c vlan.c alias.c
        ubus.c)
 
@@ -23,7 +23,8 @@ SET(LIBS
        ubox ubus uci ${json} blobmsg_json)
 
 IF (NOT DEFINED LIBNL_LIBS)
-  SET(LIBNL_LIBS -lnl)
+  FIND_LIBRARY(libnl NAMES libnl-3 libnl nl-3 nl)
+  SET(LIBNL_LIBS ${libnl})
 ENDIF()
 
 IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)