interface-ip: DNS name server sorting support in resolv.conf.auto
[project/netifd.git] / CMakeLists.txt
index ca201dc..85527be 100644 (file)
@@ -11,16 +11,15 @@ IF(APPLE)
 ENDIF()
 
 SET(SOURCES
-       main.c utils.c system.c tunnel.c
+       main.c utils.c system.c tunnel.c handler.c
        interface.c interface-ip.c interface-event.c
        iprule.c proto.c proto-static.c proto-shell.c
        config.c device.c bridge.c vlan.c alias.c
-       ubus.c)
+       macvlan.c ubus.c vlandev.c wireless.c)
 
 
-find_library(json NAMES json-c json)
 SET(LIBS
-       ubox ubus uci ${json} blobmsg_json)
+       ubox ubus uci json-c blobmsg_json)
 
 IF (NOT DEFINED LIBNL_LIBS)
   FIND_LIBRARY(libnl NAMES libnl-3 libnl nl-3 nl)