netifd: fixes for json-c 0.12
[project/netifd.git] / CMakeLists.txt
index 74cb080..85527be 100644 (file)
@@ -11,18 +11,19 @@ IF(APPLE)
 ENDIF()
 
 SET(SOURCES
-       main.c utils.c system.c tunnel.c
+       main.c utils.c system.c tunnel.c handler.c
        interface.c interface-ip.c interface-event.c
-       proto.c proto-static.c proto-shell.c
+       iprule.c proto.c proto-static.c proto-shell.c
        config.c device.c bridge.c vlan.c alias.c
-       ubus.c)
+       macvlan.c ubus.c vlandev.c wireless.c)
 
 
 SET(LIBS
-       ubox ubus uci json blobmsg_json)
+       ubox ubus uci json-c blobmsg_json)
 
 IF (NOT DEFINED LIBNL_LIBS)
-  SET(LIBNL_LIBS -lnl)
+  FIND_LIBRARY(libnl NAMES libnl-3 libnl nl-3 nl)
+  SET(LIBNL_LIBS ${libnl})
 ENDIF()
 
 IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)