proto-shell: Model config parameter "no-proto-task" as a proto flag
[project/netifd.git] / CMakeLists.txt
index 65da3cf..85527be 100644 (file)
@@ -15,12 +15,11 @@ SET(SOURCES
        interface.c interface-ip.c interface-event.c
        iprule.c proto.c proto-static.c proto-shell.c
        config.c device.c bridge.c vlan.c alias.c
-       macvlan.c ubus.c wireless.c)
+       macvlan.c ubus.c vlandev.c wireless.c)
 
 
-find_library(json NAMES json-c json)
 SET(LIBS
-       ubox ubus uci ${json} blobmsg_json)
+       ubox ubus uci json-c blobmsg_json)
 
 IF (NOT DEFINED LIBNL_LIBS)
   FIND_LIBRARY(libnl NAMES libnl-3 libnl nl-3 nl)