use calloc_a for interface error allocations
[project/netifd.git] / CMakeLists.txt
index 2062d3b..74cb080 100644 (file)
@@ -11,10 +11,12 @@ IF(APPLE)
 ENDIF()
 
 SET(SOURCES
-       main.c utils.c system.c
+       main.c utils.c system.c tunnel.c
        interface.c interface-ip.c interface-event.c
        proto.c proto-static.c proto-shell.c
-       config.c device.c bridge.c vlan.c ubus.c)
+       config.c device.c bridge.c vlan.c alias.c
+       ubus.c)
+
 
 SET(LIBS
        ubox ubus uci json blobmsg_json)
@@ -33,6 +35,9 @@ ENDIF()
 
 IF(DEBUG)
   ADD_DEFINITIONS(-DDEBUG -g3)
+  IF(NO_OPTIMIZE)
+    ADD_DEFINITIONS(-O0)
+  ENDIF()
 ENDIF()