proto-shell: move script handler dump code to handler.c
[project/netifd.git] / CMakeLists.txt
index d20b490..632d1b9 100644 (file)
@@ -1,7 +1,7 @@
 cmake_minimum_required(VERSION 2.6)
 
 PROJECT(netifd C)
-ADD_DEFINITIONS(-Os -Wall -Werror)
+ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -Wmissing-declarations)
 
 SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
 
@@ -11,16 +11,20 @@ IF(APPLE)
 ENDIF()
 
 SET(SOURCES
-       main.c utils.c
+       main.c utils.c system.c tunnel.c handler.c
        interface.c interface-ip.c interface-event.c
-       proto.c proto-static.c proto-shell.c
-       config.c device.c bridge.c vlan.c ubus.c)
+       iprule.c proto.c proto-static.c proto-shell.c
+       config.c device.c bridge.c vlan.c alias.c
+       macvlan.c ubus.c)
 
+
+find_library(json NAMES json-c json)
 SET(LIBS
-       ubox ubus uci json blobmsg_json)
+       ubox ubus uci ${json} blobmsg_json)
 
 IF (NOT DEFINED LIBNL_LIBS)
-  SET(LIBNL_LIBS -lnl)
+  FIND_LIBRARY(libnl NAMES libnl-3 libnl nl-3 nl)
+  SET(LIBNL_LIBS ${libnl})
 ENDIF()
 
 IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)
@@ -32,7 +36,10 @@ ELSE()
 ENDIF()
 
 IF(DEBUG)
-  ADD_DEFINITIONS(-DDEBUG --std=gnu99 -g3)
+  ADD_DEFINITIONS(-DDEBUG -g3)
+  IF(NO_OPTIMIZE)
+    ADD_DEFINITIONS(-O0)
+  ENDIF()
 ENDIF()