add a variable to allow forcing dummy mode on linux systems
[project/netifd.git] / CMakeLists.txt
index 8fb8ae1..5b847ec 100644 (file)
@@ -18,7 +18,7 @@ SET(SOURCES
 SET(LIBS
        ubox ubus uci json blobmsg_json)
 
 SET(LIBS
        ubox ubus uci json blobmsg_json)
 
-IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
+IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)
        SET(SOURCES ${SOURCES} system-linux.c)
        SET(LIBS ${LIBS} nl)
 ELSE()
        SET(SOURCES ${SOURCES} system-linux.c)
        SET(LIBS ${LIBS} nl)
 ELSE()