split alias support into a separate source file for better readability
[project/netifd.git] / CMakeLists.txt
index adb2c07..4ef4dfa 100644 (file)
@@ -11,10 +11,12 @@ IF(APPLE)
 ENDIF()
 
 SET(SOURCES
-       main.c utils.c
+       main.c utils.c system.c tunnel.c
        interface.c interface-ip.c interface-event.c
        proto.c proto-static.c proto-shell.c
-       config.c device.c bridge.c vlan.c ubus.c)
+       config.c device.c bridge.c vlan.c alias.c
+       ubus.c)
+
 
 SET(LIBS
        ubox ubus uci json blobmsg_json)