add support for calls to a hotplug script on interface state changes
[project/netifd.git] / CMakeLists.txt
index de0c74b..47a3509 100644 (file)
@@ -11,17 +11,19 @@ IF(APPLE)
 ENDIF()
 
 SET(SOURCES
-       main.c utils.c interface.c interface-ip.c
+       main.c utils.c
+       interface.c interface-ip.c interface-hotplug.c
        proto.c proto-static.c proto-shell.c
        config.c device.c bridge.c vlan.c ubus.c)
 
 SET(LIBS
        ubox ubus uci json blobmsg_json)
 
-IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
+IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)
        SET(SOURCES ${SOURCES} system-linux.c)
        SET(LIBS ${LIBS} nl)
 ELSE()
+       ADD_DEFINITIONS(-DDUMMY_MODE=1)
        SET(SOURCES ${SOURCES} system-dummy.c)
 ENDIF()