luci2: remove newline from generated view constructor code to make debugger line...
[project/luci2/ui.git] / luci2 / Makefile
index bdd4ac2..e83cf51 100644 (file)
@@ -37,15 +37,14 @@ endef
 define Package/luci2/install
        $(INSTALL_DIR) $(1)/www
        $(CP) ./htdocs/* $(1)/www/
-       $(INSTALL_DIR) $(1)/usr/share/luci2
-       $(CP) ./share/* $(1)/usr/share/luci2/
+       $(INSTALL_DIR) $(1)/usr/share/rpcd
+       $(CP) ./share/* $(1)/usr/share/rpcd/
        $(INSTALL_DIR) $(1)/usr/lib/rpcd
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/rpcd/luci2.so $(1)/usr/lib/rpcd/
        $(INSTALL_DIR) $(1)/usr/libexec $(1)/www/cgi-bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/io/luci2-io $(1)/usr/libexec/
        $(LN) /usr/libexec/luci2-io $(1)/www/cgi-bin/luci-upload
        $(LN) /usr/libexec/luci2-io $(1)/www/cgi-bin/luci-backup
-       $(LN) /usr/libexec/luci2-io $(1)/www/cgi-bin/luci-login
 endef
 
 define Package/luci2/postinst