luci2: Introduce 'add' option to LuCI2.cbi.AbstractValue.depends() to support increme...
[project/luci2/ui.git] / luci2 / Makefile
index 88cf3e0..06ac991 100644 (file)
@@ -37,10 +37,11 @@ endef
 define Package/luci2/install
        $(INSTALL_DIR) $(1)/www
        $(CP) ./htdocs/* $(1)/www/
-       $(INSTALL_DIR) $(1)/usr/share/luci2
-       $(CP) ./share/* $(1)/usr/share/luci2/
+       $(INSTALL_DIR) $(1)/usr/share/rpcd
+       $(CP) ./share/* $(1)/usr/share/rpcd/
        $(INSTALL_DIR) $(1)/usr/lib/rpcd
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/rpcd/luci2.so $(1)/usr/lib/rpcd/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/rpcd/bwmon.so $(1)/usr/lib/rpcd/
        $(INSTALL_DIR) $(1)/usr/libexec $(1)/www/cgi-bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/io/luci2-io $(1)/usr/libexec/
        $(LN) /usr/libexec/luci2-io $(1)/www/cgi-bin/luci-upload