luci-proto-qmi: Added support for QMI Cellular 840/head
authorDavid Thornley <david.thornley@touchstargroup.com>
Thu, 3 Nov 2016 04:55:26 +0000 (15:55 +1100)
committerDavid Thornley <david.thornley@touchstargroup.com>
Thu, 15 Dec 2016 02:34:22 +0000 (13:34 +1100)
Derived mostly from (ppp) 3g implementation. Currently exposing the following configuration through cbi (apn/pincode/username/password/auth/ipv6).

Signed-off-by: David Thornley <david.thornley@touchstargroup.com>
protocols/luci-proto-qmi/Makefile [new file with mode: 0644]
protocols/luci-proto-qmi/luasrc/model/cbi/admin_network/proto_qmi.lua [new file with mode: 0644]
protocols/luci-proto-qmi/luasrc/model/network/proto_qmi.lua [new file with mode: 0644]

diff --git a/protocols/luci-proto-qmi/Makefile b/protocols/luci-proto-qmi/Makefile
new file mode 100644 (file)
index 0000000..8b2b5e3
--- /dev/null
@@ -0,0 +1,14 @@
+#
+# Copyright (C) 2008-2014 The LuCI Team <luci@lists.subsignal.org>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=Support for QMI
+LUCI_DEPENDS:=+uqmi
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/protocols/luci-proto-qmi/luasrc/model/cbi/admin_network/proto_qmi.lua b/protocols/luci-proto-qmi/luasrc/model/cbi/admin_network/proto_qmi.lua
new file mode 100644 (file)
index 0000000..e11201d
--- /dev/null
@@ -0,0 +1,45 @@
+-- Copyright 2016 David Thornley <david.thornley@touchstargroup.com>
+-- Licensed to the public under the Apache License 2.0.
+
+local map, section, net = ...
+
+local device, apn, pincode, username, password
+local auth, ipv6
+
+
+device = section:taboption("general", Value, "device", translate("Modem device"))
+device.rmempty = false
+
+local device_suggestions = nixio.fs.glob("/dev/cdc-wdm*")
+
+if device_suggestions then
+       local node
+       for node in device_suggestions do
+               device:value(node)
+       end
+end
+
+
+apn = section:taboption("general", Value, "apn", translate("APN"))
+
+
+pincode = section:taboption("general", Value, "pincode", translate("PIN"))
+
+
+username = section:taboption("general", Value, "username", translate("PAP/CHAP username"))
+
+
+password = section:taboption("general", Value, "password", translate("PAP/CHAP password"))
+password.password = true
+
+auth = section:taboption("general", Value, "auth", translate("Authentication Type"))
+auth:value("", translate("-- Please choose --"))
+auth:value("both", "PAP/CHAP (both)")
+auth:value("pap", "PAP")
+auth:value("chap", "CHAP")
+auth:value("none", "NONE")
+
+if luci.model.network:has_ipv6() then
+    ipv6 = section:taboption("advanced", Flag, "ipv6", translate("Enable IPv6 negotiation"))
+    ipv6.default = ipv6.disabled
+end
diff --git a/protocols/luci-proto-qmi/luasrc/model/network/proto_qmi.lua b/protocols/luci-proto-qmi/luasrc/model/network/proto_qmi.lua
new file mode 100644 (file)
index 0000000..cca8af1
--- /dev/null
@@ -0,0 +1,51 @@
+-- Copyright 2016 David Thornley <david.thornley@touchstargroup.com>
+-- Licensed to the public under the Apache License 2.0.
+
+local netmod = luci.model.network
+local interface = luci.model.network.interface
+local proto = netmod:register_protocol("qmi")
+
+function proto.get_i18n(self)
+       return luci.i18n.translate("QMI Cellular")
+end
+
+function proto.ifname(self)
+       local base = netmod._M.protocol
+       local ifname = base.ifname(self) -- call base class "protocol.ifname(self)"
+
+               -- Note: ifname might be nil if the adapter could not be determined through ubus (default name to qmi-wan in this case)
+       if ifname == nil then
+               ifname = "qmi-" .. self.sid
+       end
+       return ifname
+end
+
+function proto.get_interface(self)
+       return interface(self:ifname(), self)
+end
+
+function proto.opkg_package(self)
+       return "uqmi"
+end
+
+function proto.is_installed(self)
+       return nixio.fs.access("/lib/netifd/proto/qmi.sh")
+end
+
+function proto.is_floating(self)
+       return true
+end
+
+function proto.is_virtual(self)
+       return true
+end
+
+function proto.get_interfaces(self)
+       return nil
+end
+
+function proto.contains_interface(self, ifc)
+        return (netmod:ifnameof(ifc) == self:ifname())
+end
+
+netmod:register_pattern_virtual("^qmi-%w")