luci-app-ddns: some fixes 641/head
authorChristian Schoenebeck <christian.schoenebeck@gmail.com>
Sat, 6 Feb 2016 15:33:59 +0000 (16:33 +0100)
committerChristian Schoenebeck <christian.schoenebeck@gmail.com>
Sat, 6 Feb 2016 15:33:59 +0000 (16:33 +0100)
- fixes for https://dev.openwrt.org/ticket/21787
- changed detection of BusyBox nslookup compiled with musl, thanks to Arjen de Korte

Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
applications/luci-app-ddns/Makefile
applications/luci-app-ddns/luasrc/controller/ddns.lua
applications/luci-app-ddns/luasrc/tools/ddns.lua
applications/luci-app-ddns/po/templates/ddns.pot

index 2700816..146560e 100644 (file)
@@ -10,7 +10,7 @@ PKG_NAME:=luci-app-ddns
 
 # Version == major.minor.patch
 # increase on new functionality (minor) or patches (patch)
-PKG_VERSION:=2.4.0
+PKG_VERSION:=2.4.1
 
 # Release == build
 # increase on changes of translation files
index e141d07..7cfbc56 100755 (executable)
@@ -22,7 +22,7 @@ local srv_ver_min = "2.6.0"                   -- minimum version of service required
 local srv_ver_cmd = [[/usr/lib/ddns/dynamic_dns_updater.sh --version | awk {'print $2'}]]
 local app_name    = "luci-app-ddns"
 local app_title   = "Dynamic DNS"
-local app_version = "2.4.0-1"
+local app_version = "2.4.1-1"
 
 function index()
        local nxfs      = require "nixio.fs"            -- global definitions not available
index 8868f32..5479143 100755 (executable)
@@ -16,16 +16,16 @@ local function _check_certs()
        return (v > 0)
 end
 
-has_wgetssl    = (UTIL.exec( [[which wget-ssl]] ) ~= "")       -- and true or nil
-has_curl       = (UTIL.exec( [[which curl]] ) ~= "")
-has_curlssl    = (SYS.call( [[$(which curl) -V | grep "Protocols:" | grep -qF "https"]] ) ~= 0)
+has_wgetssl    = (SYS.call( [[which wget-ssl >/dev/null 2>&1]] ) == 0) -- and true or nil
+has_curl       = (SYS.call( [[which curl >/dev/null 2>&1]] ) == 0)
+has_curlssl    = (SYS.call( [[$(which curl) -V 2>&1 | grep "Protocols:" | grep -qF "https"]] ) ~= 0)
 has_curlpxy    = (SYS.call( [[grep -i "all_proxy" /usr/lib/libcurl.so* >/dev/null 2>&1]] ) == 0)
-has_fetch      = (UTIL.exec( [[which uclient-fetch]] ) ~= "")
+has_fetch      = (SYS.call( [[which uclient-fetch >/dev/null 2>&1]] ) == 0)
 has_fetchssl   = NXFS.access("/lib/libustream-ssl.so")
-has_bbwget     = (SYS.call( [[/usr/bin/wget -V 2>&1 | grep -iqF "busybox"]] ) == 0)
-has_bindhost   = (UTIL.exec( [[which host]] ) ~= "")
-has_hostip     = (UTIL.exec( [[which hostip]] ) ~= "")
-has_nslookup   = (SYS.call( [[$(which nslookup) 127.0.0.1 0 >/dev/null 2>&1]] ) ~= 0)
+has_bbwget     = (SYS.call( [[$(which wget) -V 2>&1 | grep -iqF "busybox"]] ) == 0)
+has_bindhost   = (SYS.call( [[which host >/dev/null 2>&1]] ) == 0)
+has_hostip     = (SYS.call( [[which hostip >/dev/null 2>&1]] ) == 0)
+has_nslookup   = (SYS.call( [[$(which nslookup) localhost 2>&1 | grep -qF "(null)"]] ) ~= 0)
 has_ipv6       = (NXFS.access("/proc/net/ipv6_route") and NXFS.access("/usr/sbin/ip6tables"))
 has_ssl                = (has_wgetssl or has_curlssl or (has_fetch and has_fetchssl))
 has_proxy      = (has_wgetssl or has_curlpxy or has_fetch or has_bbwget)
index dbe317d..ba007c4 100644 (file)
@@ -1,5 +1,15 @@
 msgid ""
-msgstr "Content-Type: text/plain; charset=UTF-8"
+msgstr ""
+"Content-Type: text/plain; charset=UTF-8\n"
+"Project-Id-Version: luci-app-ddns 2.4.0-1\n"
+"POT-Creation-Date: 2016-01-30 10:15+0100\n"
+"PO-Revision-Date: \n"
+"Last-Translator: \n"
+"Language-Team: \n"
+"MIME-Version: 1.0\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-Generator: Poedit 1.8.4\n"
+"X-Poedit-SourceCharset: UTF-8\n"
 
 msgid "&"
 msgstr ""