Merge r4076 r4077 r4078
authorSteven Barth <steven@midlink.org>
Sat, 17 Jan 2009 17:59:11 +0000 (17:59 +0000)
committerSteven Barth <steven@midlink.org>
Sat, 17 Jan 2009 17:59:11 +0000 (17:59 +0000)
build/mkversion.sh [new file with mode: 0755]
contrib/package/luci/Makefile
libs/core/luasrc/init.lua
libs/core/luasrc/version.lua [new file with mode: 0644]
libs/web/root/etc/config/luci
themes/openwrt-light/luasrc/view/themes/openwrt-light/header.htm
themes/openwrt.org-oxygen/luasrc/view/themes/openwrt.org-oxygen/header.htm
themes/openwrt.org/htdocs/luci-static/openwrt.org/cascade.css
themes/openwrt.org/luasrc/view/themes/openwrt.org/header.htm

diff --git a/build/mkversion.sh b/build/mkversion.sh
new file mode 100755 (executable)
index 0000000..2361e5f
--- /dev/null
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+local variant
+
+if [ "${4%%/*}" = "branches" ]; then
+       variant="LuCI ${4##*[-/]} Branch"
+elif [ "${4%%/*}" = "tags" ]; then
+       variant="LuCI ${4##*[-/]} Release"
+else
+       variant="LuCI Trunk"
+fi
+
+cat <<EOF > $1
+module "luci.version"
+
+distname    = "${2:-OpenWrt}"
+distversion = "${3:-Development Snapshot}"
+
+luciname    = "$variant"
+luciversion = "${5:-svn}"
+EOF
index 01f7ca3..c25c4d7 100644 (file)
@@ -106,6 +106,11 @@ endef
 
 define Package/luci-core/install
        $(call Package/luci/install/template,$(1),libs/core)
+       $(PKG_BUILD_DIR)/build/mkversion.sh $(1)/usr/lib/lua/luci/version.lua \
+               "OpenWrt Firmware" \
+               "$(OPENWRTVERSION)" \
+               "$(PKG_BRANCH)" \
+               "$(PKG_VERSION)"
 endef
 
 define Package/luci-core/config
index 2eacc6c..81a65b1 100644 (file)
@@ -12,9 +12,9 @@ Copyright 2008 Steven Barth <steven@midlink.org>
 
 Licensed under the Apache License, Version 2.0 (the "License");
 you may not use this file except in compliance with the License.
-You may obtain a copy of the License at 
+You may obtain a copy of the License at
 
-       http://www.apache.org/licenses/LICENSE-2.0 
+       http://www.apache.org/licenses/LICENSE-2.0
 
 Unless required by applicable law or agreed to in writing, software
 distributed under the License is distributed on an "AS IS" BASIS,
@@ -23,7 +23,12 @@ See the License for the specific language governing permissions and
 limitations under the License.
 
 ]]--
+
+local require = require
+
 module "luci"
 
-__version__ = "0.9"
-__appname__ = "LuCI"
+local v = require "luci.version"
+
+__version__ = v.luciversion or "0.9"
+__appname__ = v.luciname    or "LuCI"
diff --git a/libs/core/luasrc/version.lua b/libs/core/luasrc/version.lua
new file mode 100644 (file)
index 0000000..9e5cb71
--- /dev/null
@@ -0,0 +1,12 @@
+--[[
+LuCI - Lua Configuration Interface
+Version definition - do not edit this file
+]]--
+
+module "luci.version"
+
+distname    = "Host System"
+distversion = "SDK"
+
+luciname    = "LuCI"
+luciversion = "SVN"
index 207b962..7c0ed5b 100644 (file)
@@ -3,12 +3,6 @@ config core main
        option mediaurlbase /luci-static/openwrt.org
        option resourcebase /luci-static/resources
        
-config core brand
-       option title    "OpenWrt Kamikaze"
-       option subtitle "Lua Configuration Interface"
-       option firmware "OpenWrt Kamikaze"
-       option distro   "Development Snapshot"
-               
 config extern flash_keep
        option uci              "/etc/config/"
        option dropbear "/etc/dropbear/"
index 7972c93..689353c 100644 (file)
@@ -59,9 +59,9 @@ require("luci.http").prepare_content("application/xhtml+xml")
 </p>
 
 <div id="header">
-<h1><%=luci.config.brand.firmware%></h1>
+<h1><%=luci.version.distname%></h1>
 <p>
-(<%=luci.config.brand.distro%>) |
+: <%=luci.version.distversion%> |
 <%:load%>: <%=load1%> <%=load5%> <%=load15%> |
 <%:hostname%>: <%=hostname%>
 </p>
index a2c48b9..fe18214 100644 (file)
@@ -61,9 +61,9 @@ require("luci.http").prepare_content("application/xhtml+xml")
 </p>
 
 <div id="header">
-<h1><%=luci.config.brand.firmware%></h1>
+<h1><%=luci.version.distname%></h1>
 <p>
-<%=luci.config.brand.distro%><br />
+<%=luci.version.distversion%><br />
 <%:load%>: <%=load1%> <%=load5%> <%=load15%><br />
 <%:hostname%>: <%=hostname%>
 </p>
index 7fb7fc8..3e68513 100644 (file)
@@ -2,19 +2,17 @@
 
 @media all {
 
-html,
 body {
+       color: #ffffff;
        background-color: #4a6b7c;
        background-image: url(bg.jpg);
        background-position: bottom center;
        background-repeat: repeat-x;
-       color: #ffffff;
-}
-
-body {
        font-family: Verdana, Arial, sans-serif;
        font-size: 101%;
        line-height: 100%;
+       height: 100%;
+       padding-bottom: 1.5em;
 }
 
 * {
index e658bfc..131e767 100644 (file)
@@ -59,9 +59,9 @@ require("luci.http").prepare_content("application/xhtml+xml")
 </p>
 
 <div id="header">
-<h1><%=luci.config.brand.firmware%></h1>
+<h1><%=luci.version.distname%></h1>
 <p>
-<%=luci.config.brand.distro%><br />
+<%=luci.version.distversion%><br />
 <%:load%>: <%=load1%> <%=load5%> <%=load15%><br />
 <%:hostname%>: <%=hostname%>
 </p>