Merge pull request #376 from chris5560/master
authorChristian Schoenebeck <christian.schoenebeck@gmail.com>
Fri, 8 May 2015 18:44:13 +0000 (20:44 +0200)
committerChristian Schoenebeck <christian.schoenebeck@gmail.com>
Fri, 8 May 2015 18:44:13 +0000 (20:44 +0200)
luci-app-radicale: New app to support Radicale CalDAV/CardDAV server

collections/luci/Makefile
luci.mk
protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_aiccu.lua

index ace4735..4625c95 100644 (file)
@@ -12,7 +12,7 @@ LUCI_BASENAME:=luci
 LUCI_TITLE:=Standard OpenWrt set including full admin with ppp support and the default Bootstrap theme
 LUCI_DEPENDS:= \
        +uhttpd +uhttpd-mod-ubus +luci-mod-admin-full +luci-theme-bootstrap \
-       +luci-app-firewall +luci-proto-ppp +libiwinfo-lua
+       +luci-app-firewall +luci-proto-ppp +libiwinfo-lua +IPV6:luci-proto-ipv6
 
 include ../../luci.mk
 
diff --git a/luci.mk b/luci.mk
index ab09f0f..d77c09e 100644 (file)
--- a/luci.mk
+++ b/luci.mk
@@ -182,7 +182,7 @@ define LuciTranslation
     CATEGORY:=LuCI
     TITLE:=$(PKG_NAME) - $(1) translation
     HIDDEN:=1
-    DEFAULT:=LUCI_LANG_$(1)||ALL
+    DEFAULT:=LUCI_LANG_$(1)||(ALL&&m)
     DEPENDS:=$(PKG_NAME)
     PKGARCH:=all
   endef
index e3ae020..9315dc2 100644 (file)
@@ -69,21 +69,21 @@ nat = section:taboption("general", Flag, "nat",
        translate("Behind NAT"),
        translate("The tunnel end-point is behind NAT, defaults to disabled and only applies to AYIYA"))
 nat.optional = true
-nat.default = disabled
+nat.default = nat.disabled
 
 
 requiretls = section:taboption("general", Flag, "requiretls",
        translate("Require TLS"),
        translate("Connection to server fails when TLS cannot be used"))
 requiretls.optional = true
-requiretls.default = requiretls.enabled
+requiretls.default = requiretls.disabled
 
 
 verbose = section:taboption("advanced", Flag, "verbose",
        translate("Verbose"),
        translate("Verbose logging by aiccu daemon"))
 verbose.optional = true
-verbose.default = disabled
+verbose.default = verbose.disabled
 
 
 ntpsynctimeout = section:taboption("advanced", Value, "ntpsynctimeout",