luci.mk: don't builtin translations selected by CONFIG_ALL
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 5 May 2015 08:32:15 +0000 (10:32 +0200)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 5 May 2015 08:32:15 +0000 (10:32 +0200)
Make sure that translation packages enabled through CONFIG_ALL
that depend on builtin packages are restricted to modules.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
luci.mk

diff --git a/luci.mk b/luci.mk
index ab09f0f..d77c09e 100644 (file)
--- a/luci.mk
+++ b/luci.mk
@@ -182,7 +182,7 @@ define LuciTranslation
     CATEGORY:=LuCI
     TITLE:=$(PKG_NAME) - $(1) translation
     HIDDEN:=1
     CATEGORY:=LuCI
     TITLE:=$(PKG_NAME) - $(1) translation
     HIDDEN:=1
-    DEFAULT:=LUCI_LANG_$(1)||ALL
+    DEFAULT:=LUCI_LANG_$(1)||(ALL&&m)
     DEPENDS:=$(PKG_NAME)
     PKGARCH:=all
   endef
     DEPENDS:=$(PKG_NAME)
     PKGARCH:=all
   endef