Remove remaining references to boa and lucid
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 11 Jun 2014 12:37:22 +0000 (12:37 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 11 Jun 2014 12:37:22 +0000 (12:37 +0000)
Makefile
contrib/package/luci-addons/Makefile
contrib/package/luci/Makefile

index 362eed6..b99e8f7 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -60,9 +60,6 @@ sdk:
 ucidefaults:
        build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath host)/bin/uci-defaults --exclude luci-freifunk-*"
 
-runhttpd: hostenv
-       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "lua build/lucid.lua"
-
 runuhttpd: hostenv
        cp $(realpath build)/luci.cgi $(realpath host)/www/cgi-bin/luci
        build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath host)/usr/sbin/uhttpd -p 8080 -h $(realpath host)/www -f"
@@ -92,11 +89,8 @@ run:
        #       make run is deprecated                          #
        #       Please use:                                     #
        #                                                       #
-       #       To run LuCI WebUI using LuCIttpd                #
-       #       make runhttpd                                   #
-       #                                                       #
-       #       To run LuCI WebUI using Boa/Webuci              #
-       #       make runboa                                     #
+       #       To run LuCI WebUI using uhttpd                  #
+       #       make runuhttpd                                  #
        #                                                       #
        #       To start a shell in the LuCI environment        #
        #       make runshell                                   #
index c1c0992..c223054 100644 (file)
@@ -262,7 +262,7 @@ define Build/Prepare
        mkdir -p $(PKG_BUILD_DIR)
        $(TAR) c -C $(LUCI_TOPDIR) . \
                --exclude=.pc --exclude=.svn --exclude=.git \
-               --exclude='boa-0*' --exclude='*.o' --exclude='*.so' \
+               --exclude='*.o' --exclude='*.so' \
                --exclude=dist | \
                        tar x -C $(PKG_BUILD_DIR)/
        $(call Build/Prepare/Default)
index 5d81d43..8bb3531 100644 (file)
@@ -423,7 +423,7 @@ define Build/Prepare
        mkdir -p $(PKG_BUILD_DIR)
        $(TAR) c -C $(LUCI_TOPDIR) . \
                --exclude=.pc --exclude=.svn --exclude=.git \
-               --exclude='boa-0*' --exclude='*.o' --exclude='*.so' \
+               --exclude='*.o' --exclude='*.so' \
                --exclude=dist | \
                        tar x -C $(PKG_BUILD_DIR)/
        $(call Build/Prepare/Default)