contrib: remove obsolete uhttpd packaging
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 2 Sep 2015 07:41:35 +0000 (09:41 +0200)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 2 Sep 2015 07:41:35 +0000 (09:41 +0200)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
contrib/uhttpd/Makefile [deleted file]
contrib/uhttpd/patches/001-pass-env.patch [deleted file]
contrib/uhttpd/patches/002-link-order.patch [deleted file]
contrib/uhttpd/patches/series [deleted file]

diff --git a/contrib/uhttpd/Makefile b/contrib/uhttpd/Makefile
deleted file mode 100644 (file)
index 930bf9a..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-include ../../build/config.mk
-include ../../build/gccconfig.mk
-
-UHTTPD_SRC             = svn://svn.openwrt.org/openwrt/branches/backfire/package/uhttpd/src
-UHTTPD_DIR             = uhttpd-src
-UHTTPD_PATCHDIR = patches
-
-all: compile
-
-include ../../build/module.mk
-
-$(UHTTPD_DIR)/Makefile:
-       svn co $(UHTTPD_SRC) $(UHTTPD_DIR)
-
-$(UHTTPD_DIR)/.prepared: $(UHTTPD_DIR)/Makefile
-       (cd $(UHTTPD_PATCHDIR); ls *.patch | sort > series) || true
-       [ -f "$(UHTTPD_PATCHDIR)/series" ] && while read patch; do \
-               patch -d $(UHTTPD_DIR) -p1 < $(UHTTPD_PATCHDIR)/$$patch; \
-       done < $(UHTTPD_PATCHDIR)/series || true
-       touch $@
-
-compile: $(UHTTPD_DIR)/.prepared
-       (cd $(UHTTPD_DIR); $(MAKE) LUA_SUPPORT=0 TLS_SUPPORT=0 CGI_SUPPORT=1)
-       mkdir -p dist/usr/sbin
-       cp $(UHTTPD_DIR)/uhttpd dist/usr/sbin
-
-compile-all: compile
-
-clean:
-       rm -rf $(UHTTPD_DIR)
diff --git a/contrib/uhttpd/patches/001-pass-env.patch b/contrib/uhttpd/patches/001-pass-env.patch
deleted file mode 100644 (file)
index ab607db..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/uhttpd-cgi.c
-+++ b/uhttpd-cgi.c
-@@ -216,7 +216,7 @@ void uh_cgi_request(
-                            (pi->stat.st_mode & S_IXOTH)) || (ip != NULL)
-                       ) {
-                               /* build environment */
--                              clearenv();
-+                              //clearenv();
-                               /* common information */
-                               setenv("GATEWAY_INTERFACE", "CGI/1.1", 1);
diff --git a/contrib/uhttpd/patches/002-link-order.patch b/contrib/uhttpd/patches/002-link-order.patch
deleted file mode 100644 (file)
index 8bdd335..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -70,7 +70,7 @@ endif
-       $(CC) $(CFLAGS) -c -o $@ $<
- compile: $(OBJ) $(TLSLIB) $(LUALIB)
--      $(CC) -o uhttpd $(LDFLAGS) $(LIB) $(OBJ)
-+      $(CC) -o uhttpd $(LDFLAGS) $(OBJ) $(LIB)
- clean:
-       rm -f *.o *.so uhttpd
diff --git a/contrib/uhttpd/patches/series b/contrib/uhttpd/patches/series
deleted file mode 100644 (file)
index 8a1834e..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-001-pass-env.patch
-002-link-order.patch